Bug 176004 - mouse cursor look like default X11 instead of themed ones
mouse cursor look like default X11 instead of themed ones
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: redhat-artwork (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
:
Depends On:
Blocks: FC5Blocker
  Show dependency treegraph
 
Reported: 2005-12-17 02:34 EST by Kaj J. Niemi
Modified: 2013-01-09 22:40 EST (History)
9 users (show)

See Also:
Fixed In Version: 0.131-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-13 14:08:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Kaj J. Niemi 2005-12-17 02:34:11 EST
Description of problem:
I noticed that with recent rawhides the mouse cursors somehow are stock X11
instead of the themed ones. I'm kind of unsure when this happened or how to fix
it. There are cursor icons in /usr/share/icons/Theme/cursors/ and things look
normal that way.

Version-Release number of selected component (if applicable):
xorg-x11-xkb-utils-0.99.1-2.i386
xorg-x11-drv-savage-2.0.2-1.i386
xorg-x11-drv-sis-0.8.1-1.i386
xorg-x11-drv-vga-4.0.0.2-1.i386
xorg-x11-drv-fbdev-0.1.0.2-1.i386
xorg-x11-drv-void-1.0.0.2-1.i386
xorg-x11-drv-i810-1.4.1-1.i386
xorg-x11-drv-vesa-1.0.1-1.i386
xorg-x11-drv-mutouch-1.0.0.2-1.i386
xorg-x11-fonts-Type1-0.99.0-8.noarch
xorg-x11-drv-via-0.1.31.1-1.i386
xorg-x11-drv-glint-1.0.1-1.i386
xorg-x11-drv-citron-2.1.1.2-1.i386
xorg-x11-drv-penmount-1.0.0.2-1.i386
xorg-x11-drv-elographics-1.0.0.2-1.i386
xorg-x11-drv-nv-1.0.1.2-1.i386
xorg-x11-drv-aiptek-1.0.0.2-1.i386
xorg-x11-drv-hyperpen-1.0.0.2-1.i386
xorg-x11-font-utils-0.99.1-1.i386
xorg-x11-filesystem-0.99.2-3.noarch
xorg-x11-xdm-0.99.3-6.i386
xorg-x11-fonts-base-0.99.0-8.noarch
xorg-x11-fonts-misc-0.99.0-8.noarch
xorg-x11-proto-devel-0.99.3-1.i386
xorg-x11-xkbdata-0.99.1-2.noarch
xorg-x11-drivers-0.99.2-4.i386
xorg-x11-server-Xorg-0.99.3-9.i386
xorg-x11-fonts-ISO8859-1-100dpi-0.99.0-8.noarch
xorg-x11-utils-0.99.2-3.i386
xorg-x11-xfwp-0.99.1-3.i386
xorg-x11-drv-i740-1.0.0.2-1.i386
xorg-x11-drv-i128-1.1.0.2-1.i386
xorg-x11-drv-neomagic-1.0.0.2-1.i386
xorg-x11-drv-vmware-10.11.1-1.i386
xorg-x11-drv-siliconmotion-1.3.1.2-1.i386
xorg-x11-drv-tseng-1.0.0.2-1.i386
xorg-x11-drv-dummy-0.1.0.2-1.i386
xorg-x11-drv-ark-0.5.0.2-1.i386
xorg-x11-drv-joystick-1.0.0.2-1.i386
xorg-x11-drv-apm-1.0.1.2-1.i386
xorg-x11-drv-nsc-2.7.6.2-1.i386
xorg-x11-drv-tdfx-1.1.1-1.i386
xorg-x11-drv-magellan-1.0.0.2-1.i386
xorg-x11-xinit-0.99.3-6.i386
xorg-x11-drv-dynapro-1.0.0.2-1.i386
xorg-x11-apps-0.99.2-4.i386
xorg-x11-fonts-ISO8859-1-75dpi-0.99.0-8.noarch
xorg-x11-fonts-100dpi-0.99.0-8.noarch
xorg-x11-server-utils-0.99.2-6.i386
xorg-x11-resutils-0.99.1-3.i386
xorg-x11-drv-s3virge-1.8.6.2-1.i386
xorg-x11-drv-s3-0.3.5.2-1.i386
xorg-x11-drv-summa-1.0.0.2-1.i386
xorg-x11-drv-chips-1.0.1-1.i386
xorg-x11-drv-voodoo-1.0.0.2-1.i386
xorg-x11-drv-cirrus-1.0.0.2-1.i386
xorg-x11-drv-magictouch-1.0.0.2-1.i386
xorg-x11-drv-rendition-4.0.1-1.i386
xorg-x11-drv-evdev-1.0.0.2-1.i386
xorg-x11-drv-mga-1.2.1-1.i386
xorg-x11-drv-cyrix-1.0.0.2-1.i386
xorg-x11-drv-microtouch-1.0.0.2-1.i386
xorg-x11-drv-digitaledge-1.0.1-1.i386
xorg-x11-drv-ati-6.5.7-1.i386
xorg-x11-drv-elo2300-1.0.0.2-1.i386
xorg-x11-drv-fpit-1.0.0.2-1.i386
xorg-x11-drv-dmc-1.0.0.2-1.i386
xorg-x11-drv-sisusb-0.7.1-1.i386
xorg-x11-drv-spaceorb-1.0.0.2-1.i386
xorg-x11-drv-calcomp-1.0.0.2-1.i386
xorg-x11-drv-palmax-1.0.0.2-1.i386
xorg-x11-drv-mouse-1.0.1-2.i386
xorg-x11-drv-ur98-1.0.0.2-1.i386
xorg-x11-fonts-75dpi-0.99.0-8.noarch
xorg-x11-xfs-0.99.2-4.i386
xorg-x11-xauth-0.99.2-1.i386
xorg-x11-drv-keyboard-1.0.1-1.i386
xorg-x11-drv-jamstudio-1.0.0.2-1.i386
xorg-x11-drv-trident-1.0.0.2-1.i386
xorg-x11-drv-acecad-1.0.0.2-1.i386


Actual results:
X11 mouse cursors

Expected results:
Nice themed bluecurve cursors maybe?

Additional info:
On a related item, the Cursors page is empty in "Mouse preferences".. I guess
this is part of control-center.

Thanks :)
Comment 1 Kaj J. Niemi 2005-12-17 02:41:16 EST
Playing around with gconftool-2 returns the following (note Bluecurve set as
cursor theme):

..
 /desktop/gnome/peripherals:
  /desktop/gnome/peripherals/mouse:
   double_click = 400
   single_click = true
   drag_threshold = 8
   cursor_font = (no value set)
   left_handed = false
   locate_pointer = false
   cursor_theme = Bluecurve
   motion_acceleration = -1
   motion_threshold = -1
   cursor_size = 24

Comment 2 Kaj J. Niemi 2005-12-19 01:38:55 EST
Running control-center's gnome-mouse-properties from the command line prints out:

(gnome-mouse-properties:2832): -properties-CRITICAL **: cursor_theme_changed:
assertion `gtk_tree_model_get_iter_first (model, &iter)' failed

Maybe this is more of a gnome-issue than a X11 issue..
Comment 3 Thomas M Steenholdt 2005-12-23 07:26:39 EST
Same problem here!
Comment 4 Thomas M Steenholdt 2005-12-23 07:35:13 EST
...And I don't think its a gnome (only) problem, since KDE in rawhide behaves in
exactly the same way???
Did the format or path or whatever change for these versions of things or something?
Comment 5 Bart Vanbrabant 2005-12-26 07:59:17 EST
I've got the same problem. First my gdm had the X11 cursors a few days later
after some rawhide updates also my gnome desktop got affected with those very
ugly cursors
Comment 6 Pierre Ossman 2005-12-28 15:19:53 EST
The reason it doesn't work is quite simple. The files are empty. :)

[root@poseidon cursors]# ll /usr/share/icons/Bluecurve/cursors/left_ptr
-rw-r--r-- 1 root root 0 10 dec 10.44 /usr/share/icons/Bluecurve/cursors/left_ptr

Component should be changed to redhat-artwork (original reporter can do this).
Comment 7 Thomas M Steenholdt 2005-12-28 18:35:01 EST
i'm seing the same thing, so in an attempt to try to corner the problem i
installed the redhat-artwork src.rpm and rpmbuild -ba'ed it. rpm -Uvh --force'd
the outcome rpm and my left_ptr (and others) are no longer 0 bytes - And the
cursors are now bluecurve cursors the way they should be. note that the src.rpm
i rebuilt and the installed redhat-artwork package was the exact same version,
so something is probably rotten in some way on the build system...?
Comment 8 Bill Crawford 2005-12-28 19:15:03 EST
It's also fixable by going into the directory and running:

for config in *.cfg ; do xcursorgen $config ${config%.cfg} ; done
Comment 9 John (J5) Palmieri 2005-12-29 08:49:33 EST
looks like a build machine borkage.  I have the same issues.  I take a look when
I get back to the office on tuesday.
Comment 10 Christopher Aillon 2006-01-13 01:34:03 EST
This should really get fixed for FC5.
Comment 11 Christopher Aillon 2006-01-13 14:08:41 EST
I just took time to figure this one out.  So, here's what happened:

xcursorgen got moved into the xorg-x11-apps package.
When building the RPM, there would be errors about missing xcursorgen, but the
build did not fail for some strange reason (NOTE: we should investigate that).

Simply adding a BR on xorg-x11-apps fixes this.  I've rebuilt with this fix, so
next time there's an update available, enjoy!
Comment 12 Andy Burns 2006-01-14 10:56:47 EST
Confirmed fixed worked for me in rawhide 2006-01-14

Note You need to log in before you can comment on or make changes to this bug.