Bug 176015 - java dependency nightmare - circular dependencies
java dependency nightmare - circular dependencies
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: medor (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Deepak Bhole
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-17 10:45 EST by John Ellson
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-04 13:31:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Ellson 2005-12-17 10:45:47 EST
Description of problem:
medor depends on jorm, jorm depends on medor

I suppose rpm can probably handle it, but its bad package design.

Version-Release number of selected component (if applicable):
medor-1.4.4-1jpp_2fc
jorm-2.4.3-1jpp_2fc.1

How reproducible:
100%

Steps to Reproduce:
1.rpm -Uvh jorm-2.4.3-1jpp_2fc.1.noarch.rpm
2.rpm -Uvh medor-1.4.4-1jpp_2fc.noarch.rpm
3.
  
Actual results:
error: Failed dependencies:
        medor is needed by jorm-2.4.3-1jpp_2fc.1.noarch
...
error: Failed dependencies:
        jorm is needed by medor-1.4.4-1jpp_2fc.noarch
...

Expected results:
No circular dependencies

Additional info:
Comment 1 Gary Benson 2005-12-22 04:14:03 EST
To install these packages they must both be in the same rpm transaction:

  rpm -Uvh jorm-2.4.3-1jpp_2fc.1.noarch.rpm medor-1.4.4-1jpp_2fc.noarch.rpm

Unfortunatly these versions of jorm and medor are pretty much inextricably
linked: it's not possible to, for example, extract non-medor bits of jorm into a
separate package and use that to build medor because there are no non-medor bits
of jorm (and vice versa: there're no non-jorm bits of medor either).

Deepak Bhole has persuaded the upstream developers to decouple these packages
which they have done.  When Fedora is upgraded to the new versions this
particular circular dependency will go away.
Comment 2 Deepak Bhole 2007-06-04 13:31:13 EDT
jorm/medor are no longer in Fedora. Closing this one..

Note You need to log in before you can comment on or make changes to this bug.