Bug 176019 - kernel 2.6.14-1.1653_FC4 hangs when booting (�cups?)
kernel 2.6.14-1.1653_FC4 hangs when booting (�cups?)
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-17 11:19 EST by Sanse
Modified: 2015-01-04 17:23 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-08 17:39:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sanse 2005-12-17 11:19:09 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050923 Fedora/1.7.12-1.5.1

Description of problem:
I have updated kernel-2.6.14-1.1653_FC4 using yum.

When I try to boot it freezes in the middle proccess. It looks like it hangs the computer when the kernel try to start cups at booting time.


Version-Release number of selected component (if applicable):
kernel-2.6.14-1.1653_FC4

How reproducible:
Always

Steps to Reproduce:
1. yum update kernel
2. Turn on the computer
3. Select kernel from grub
  

Additional info:
Comment 1 Bill Marrs 2005-12-18 10:34:40 EST
I just updated 4 servers to 1653_FC4, 3 came up fine, but the 4th is getting a 
kernel panic early in the boot, I think because it's failing to mount the root 
file system.   Going back to the previous kernel 1644_FC4 fixes the problem for 
me.

I'm having trouble gathering useful data because there's no log of the boot as 
far as I can tell (makes sense, I guess, since the problem occurs before it 
mounts the filesystem).  I think I'll try forcing a re-install of the 1653_FC4 
kernel.

My system is SMP and has software RAID as well.  Another one of my servers is 
virtually identical hardware and software, but it's OK.
Comment 2 Bill Marrs 2005-12-18 10:35:29 EST
p.s.  My system isn't using cups.
Comment 3 Sanse 2005-12-18 15:40:00 EST
This is definetely a problem "kernel versus CUPS".

I have intalled: cups.i386 1:1.1.23-15.2 installed

Now if I boot the 1653_FC4 without cups enable in level 3 (service
configuration) the kernel boots fine. 

But then when I try to start CUPS (service configuration) the machine hangs.

I have a 2 computer WLAN (wireless). This computer has a printer shared (using
samba and CUPS) so I need CUPS to print. I think here there is the real problem:
with the 1653_FC4 kernel CUPS does not start and frezze my computer.

Just in case, my WLAN is a wireless one. I use a CONCEPTRONIC USB CRU device
with drivers from http://rt2x00.sourceforge.net (package rt2570-cvs-2005121511,
rt2570 Module).

P.S. Whith 1644_FC4 kernel, CUPS fail to start on booting but I can start it
when the LAN is running.
Comment 4 Dave Jones 2005-12-19 22:31:11 EST
do either of you actually have a printer ? If so, what type? (Parallel/usb ?)
Comment 5 Sanse 2005-12-20 03:50:12 EST
The printer is a EPSON 660 connected throuugh the paralallel port to the same 
computer with de problem. It works fine with 1644_FC4 kernel. I think the 
printer does not have anything to do with de bug. 

From my point of view the bug is that the 1653_FC4 kernel is not able to start 
CUPS, perhaps because of the share services of the LAN (WLAN) configuration, 
and hangs the computer.
Comment 6 Bill Marrs 2005-12-20 07:30:15 EST
My boot kernel panic with 2.6.14-1.1653_FC4 is not related to cups or printing 
(neither are installed on this server).  I think this is just the wrong place 
for my bug, I'm out of here. Maybe, I'll post a new bug for my issue.

 good luck
Comment 7 Sanse 2006-01-08 17:39:47 EST
I have just updated to kernel-2.6.14-1.1656_FC4 using yum.

Now it boots fine.

CUPS still fails to start at boot time but I can restart it when my wireless LAN
is running, just the same as with 1644 and previous kernels. 

I have removed the kernel-2.6.14-1.1653_FC4 (bye!, ¡Adios!).

It looks like the problem was related with kernel-2.6.14-1.1653_FC4 when start CUPS.

Cheers,

LINUX ERGO SUM

PD: For devices and hardware information, the wireless device CONCEPTRONIC USB
C54RU works fine with rt2570 USB nightly CVS tarball.
(http://rt2x00.serialmonkey.com/wiki/index.php/Downloads).

Note You need to log in before you can comment on or make changes to this bug.