Bug 1760215 - mgr/volumes: creating FS subvolume and subvolume group snapshot fails
Summary: mgr/volumes: creating FS subvolume and subvolume group snapshot fails
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: CephFS
Version: 4.0
Hardware: All
OS: All
high
medium
Target Milestone: rc
: 4.0
Assignee: Jos Collin
QA Contact: ymane
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-10-10 07:36 UTC by Ram Raja
Modified: 2020-01-31 12:47 UTC (History)
7 users (show)

Fixed In Version: ceph-14.2.4-33.el8cp, ceph-14.2.4-2.el7cp
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-31 12:47:11 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Ceph Project Bug Tracker 42180 0 None None None 2019-10-10 07:53:34 UTC
Red Hat Product Errata RHBA-2020:0312 0 None None None 2020-01-31 12:47:31 UTC

Description Ram Raja 2019-10-10 07:36:09 UTC
Description of problem:
Creating FS subvolume and subvolumegroup snapshot fails


How reproducible: Always


Steps to Reproduce:
Create a Ceph filesystem.

Within a Ceph client with 'admin' cephx auth ID issue the following commands (substitute your filesystem's name),

$ # Create a FS subvolume 
$ ceph fs subvolume create <fs-name> subvol00

$ # Try creating its snapshot.
$ ceph fs subvolume snapshot create <fs-name> subvol00 snap00

$ # Create a FS subvolume group
$ ceph fs subvolumegroup create <fs-name> gp00

4. # Try creating its snapshot
$ ceph fs subvolumegroup snapshot create <fs-name> gp00 snap00

Actual results:
`fs subvolume snapshot create` and `fs subvolumegroup snapshot create` commands fail.


Expected results:
Snapshot creations should succeed.

Comment 8 errata-xmlrpc 2020-01-31 12:47:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0312


Note You need to log in before you can comment on or make changes to this bug.