Bug 176024 - Repeated 'No medium found' warnings from /dev/sd[bcde]
Repeated 'No medium found' warnings from /dev/sd[bcde]
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-17 14:27 EST by David Woodhouse
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-22 11:35:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Anaconda log (683.17 KB, text/plain)
2005-12-19 20:22 EST, David Woodhouse
no flags Details

  None (edit)
Description David Woodhouse 2005-12-17 14:27:33 EST
My monitor has a whole bunch of CF/MMC/etc sockets, which all appear as
usb-storage devices. At many stages during the install, I get dialog boxes
popping up to complain that no medium was found in each of these. Not only do I
get four consecutive such warnings on each occasion, but it also happens many
times in a row sometimes, without anything else happening in between.
Comment 1 Jeremy Katz 2005-12-19 13:13:51 EST
Hmmm, they should get ignored by the removable device check.  Can you install
the anaconda package and run

PYTHONPATH=/usr/lib/anaconda python -c 'import isys; print
isys.driveIsRemovable("sdb")'
Comment 2 David Woodhouse 2005-12-19 15:28:42 EST
Running in a chroot on the Fedora Core 4 kernel I get 'True'. Reproducing on the
correct kernel will take a little longer...
Comment 3 David Woodhouse 2005-12-19 15:32:14 EST
... except that the beauty of USB devices is that you can so easily remove them
and plug them into other machines temporarily. On a rawhide machine with
kernel-2.6.14-1.1718_FC5 and anaconda-10.90.21-1 it also returns True.
Comment 4 David Woodhouse 2005-12-19 20:22:30 EST
Created attachment 122432 [details]
Anaconda log

/tmp/anaconda.log from the install. I thought this was supposed to be copied
into the installed filesystem afterwards, but it doesn't seem to be there. The
/root/install.log and /root/install.log.syslog contain almost nothing of note.
Comment 5 Paul Nasrat 2005-12-20 07:05:53 EST
/var/log/anaconda.log /var/log/anaconda.syslog
Comment 6 David Woodhouse 2005-12-20 09:14:25 EST
Ah, thanks. I assume you don't want to see the syslog because the STMF check is
already implicated by anaconda.log? We just need to make that happen only on
iSeries and/or only on non-removable devices? 
Comment 7 Jeremy Katz 2005-12-22 11:35:16 EST
Should be fixed in CVS

Note You need to log in before you can comment on or make changes to this bug.