Bug 176027 - kicker crashing at logout
kicker crashing at logout
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
4
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-17 15:41 EST by Adam Pribyl
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-22 06:41:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attempt at fixing kicker (panel) crashing on logout (1.07 KB, patch)
2005-12-19 07:58 EST, Niko Mirthes
no flags Details | Diff

  None (edit)
Description Adam Pribyl 2005-12-17 15:41:24 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.7.11) Gecko/20050728

Description of problem:
You could treat this as duplicate of #160740, but this report is about latest update to KDE 3.5 in FC4 - maybe some KDE regression. Till that day I never saw kicker crashing at logout, now it is almost every time. Could be x86_64 specific.



Version-Release number of selected component (if applicable):
kdebase-3.5.0-0.1.fc4

How reproducible:
Sometimes

Steps to Reproduce:
1. start KDE: startx -- :1
2. play with something for a while
3. logout
  

Actual Results:  Here is KCrash output:
(no debugging symbols found)
Using host libthread_db library "/lib64/libthread_db.so.1".
(no debugging symbols found) 23x
[Thread debugging using libthread_db enabled]
[New Thread 46912516228256 (LWP 12899)]
(no debugging symbols found) 40x
[KCrash handler]
#3  0x0000003cd66e45d8 in QGList::findRef ()
   from /usr/lib64/qt-3.3/lib/libqt-mt.so.3
#4  0x0000003cd66e52fd in QGList::removeRef ()
   from /usr/lib64/qt-3.3/lib/libqt-mt.so.3
#5  0x00002aaaaae7ecf0 in KDirListerCache::forgetDirs ()
   from /usr/lib64/libkio.so.4
#6  0x00002aaaaae7f570 in KDirListerCache::forgetDirs ()
   from /usr/lib64/libkio.so.4
#7  0x00002aaaaae7f7ae in KDirLister::~KDirLister ()
   from /usr/lib64/libkio.so.4
#8  0x00002aaab0714f98 in SystemMenu::~SystemMenu$delete ()
   from /usr/lib64/kde3/kickermenu_systemmenu.so
#9  0x0000003cd66e5536 in QGList::clear ()
   from /usr/lib64/qt-3.3/lib/libqt-mt.so.3
#10 0x00002aaaab957e42 in KLibrary::~KLibrary$delete ()
   from /usr/lib64/libkdecore.so.4
#11 0x00002aaaab958fc2 in KLibLoader::close_pending ()
   from /usr/lib64/libkdecore.so.4
#12 0x00002aaaab959346 in KLibLoader::~KLibLoader$delete ()
   from /usr/lib64/libkdecore.so.4
#13 0x00002aaaab9572e6 in KLibLoader::cleanUp ()
   from /usr/lib64/libkdecore.so.4
#14 0x00002aaaab8c6eaa in KApplication::~KApplication$base ()
   from /usr/lib64/libkdecore.so.4
#15 0x00002aaaaf3af9a9 in Kicker::~Kicker$delete ()
   from /usr/lib64/libkdeinit_kicker.so
#16 0x00002aaaaf3af599 in kdemain () from /usr/lib64/libkdeinit_kicker.so
#17 0x0000000000406f94 in ?? ()
#18 0x00000000004075c3 in ?? ()
#19 0x0000000000407c6d in ?? ()
#20 0x0000000000408c08 in ?? ()
#21 0x0000003231c1c3cf in __libc_start_main () from /lib64/libc.so.6
#22 0x0000000000404b69 in ?? ()
#23 0x00007fffffd96a58 in ?? ()
#24 0x0000000000000000 in ?? ()

Logout is delayed as kicker is restarting...

Expected Results:  Obvious.

Additional info:

Clean profile, no changes in KDE.
Comment 1 Niko Mirthes 2005-12-18 18:35:44 EST
According to the upstream maintainer, this bug is known. Apparently it was fixed
for release, then mistakenly reverted prior to tagging for KDE 3.5 release. It's
fixed upstream in KDE's svn repo, so a patch can be made, or wait for 3.5.1.
I believe this can be avoided by not adding any (or removing any existing)
Action menus to the main menu (kmenu). These can be added and removed in Control
Center (kcontrol), found in the "Option Menus" at Desktop -> Panels -> Menus
Comment 2 Niko Mirthes 2005-12-19 07:58:06 EST
Created attachment 122399 [details]
Attempt at fixing kicker (panel) crashing on logout

I've gone ahead and made a diff against upstream that seems to fix this
problem. I've been using it for the last few hours and it seems fine so far.
Comment 3 Adam Pribyl 2005-12-19 08:18:28 EST
Thanks for all your attention. I am sorry I can not help you with testing of
this patch, but if there is any rpm devel build I can test it.
Comment 4 Niko Mirthes 2005-12-19 17:12:20 EST
This is already fixed in rawhide, apparently. In the future, it'd be nice to get
some feedback from someone@redhat.com so people can avoid wasting time and effort.
Comment 5 Luc Lalonde 2005-12-20 11:54:59 EST
I confirm that the patch fixes kdelibs-3.5.0-0.1.fc4.

Thanks 
Comment 6 Ngo Than 2005-12-21 06:53:34 EST
Niko, many thanks for the patch. I don't think it's fixed in the rawhide,
because it's the same tar file from FC4!




Comment 7 Niko Mirthes 2005-12-21 12:14:45 EST
Oh, ok. Thank you, Than. Someone in #fedora-devel on freenode seemed to think it
was fixed in rawhide. Any chance of applying this patch and updating in the near
future?
Comment 8 Ngo Than 2005-12-21 12:19:20 EST
i even built new kdelibs with this patch in rawhide. it should be available in
rawhide soon. For FC4 update, it will be pushed out this weekend.
Comment 9 Adam Pribyl 2005-12-22 13:19:21 EST
Seems fixed, thanks.

Note You need to log in before you can comment on or make changes to this bug.