Bug 1760302 - etckeeper-bzr fails to install in Fedora rawhide (switch to breezy maybe?)
Summary: etckeeper-bzr fails to install in Fedora rawhide (switch to breezy maybe?)
Keywords:
Status: CLOSED DUPLICATE of bug 1741027
Alias: None
Product: Fedora
Classification: Fedora
Component: etckeeper
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Thomas Moschny
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F32FailsToInstall PY2FTBI
TreeView+ depends on / blocked
 
Reported: 2019-10-10 11:01 UTC by Miro Hrončok
Modified: 2019-10-10 11:46 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-10 11:46:34 UTC
Type: Bug


Attachments (Terms of Use)

Description Miro Hrončok 2019-10-10 11:01:48 UTC
etckeeper-bzr-1.18.10-4.fc32.noarch fails to install in Fedora rawhide:

  package etckeeper-bzr-1.18.10-4.fc32.noarch requires bzr, but none of the providers can be installed
  nothing provides python2-paramiko needed by bzr-2.7.0-23.fc30.x86_64

This is caused by broken bazaar.

An attempted fix it to replace bazaar with breezy, see https://fedoraproject.org/wiki/Changes/ReplaceBazaarWithBreezy

Before the change is accepted, breezy was packaged (command brz).

Is it possible to switch etckeeper-bzr to breezy (and Python 3)?

Comment 1 Thomas Moschny 2019-10-10 11:40:12 UTC
That's the plan, yes (discussed in bug 1741027).

I hope to be able to look at it at the weekend.

Comment 2 Miro Hrončok 2019-10-10 11:46:34 UTC
OK, let's merge the bugz.

*** This bug has been marked as a duplicate of bug 1741027 ***


Note You need to log in before you can comment on or make changes to this bug.