Bug 176032 - Wrongly-generated yaboot.conf
Wrongly-generated yaboot.conf
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: booty (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Jones
:
Depends On:
Blocks: FC5Target
  Show dependency treegraph
 
Reported: 2005-12-17 17:47 EST by David Woodhouse
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-11 16:26:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
install.log (31.25 KB, text/plain)
2005-12-17 18:29 EST, David Woodhouse
no flags Details
install.log.syslog (3.72 KB, text/plain)
2005-12-17 18:29 EST, David Woodhouse
no flags Details
anaconda-ks.cfg (890 bytes, text/plain)
2005-12-17 18:31 EST, David Woodhouse
no flags Details

  None (edit)
Description David Woodhouse 2005-12-17 17:47:12 EST
My partition table looks like this...

Disk geometry for /dev/sda: 0.000-239372.437 megabytes
Disk label type: mac
Minor    Start       End     Filesystem  Name                  Flags
1          0.000      0.031              Apple
2          0.031      1.031  hfs         untitled              boot
3          1.031 220001.031  ext3        untitled
4     220001.031 222049.031  hfs         swap                  swap
5     222049.031 239372.437  ext3        untitled

sda5 was originally free space, used as the root partition for the rawhide
installation I just attempted; hda3 was not part of that system. 

The resulting /etc/yaboot.conf written by the installer contained this line:
boot=/dev/sda2 /dev/sda4

This causes ybin/mkofboot to be slightly unhappy, and also the boot-device
environment variable seems to have been set to hd:4, instead of hd:2.
Comment 1 Peter Jones 2005-12-17 18:19:31 EST
Do you have the install logs handy?

"boot=/dev/sda2 /dev/sda4" looks like booty thinks it's setting up a raid1
device for /boot, which is obviously really strange given what you've said here.
Comment 2 David Woodhouse 2005-12-17 18:28:45 EST
They didn't seem wonderfully enlightening, which is why I didn't attach them.
Comment 3 David Woodhouse 2005-12-17 18:29:14 EST
Created attachment 122372 [details]
install.log
Comment 4 David Woodhouse 2005-12-17 18:29:57 EST
Created attachment 122373 [details]
install.log.syslog
Comment 5 David Woodhouse 2005-12-17 18:31:37 EST
Created attachment 122374 [details]
anaconda-ks.cfg
Comment 6 Peter Jones 2005-12-17 18:53:12 EST
No kidding, they don't seem enlightening at all.
Comment 7 David Woodhouse 2005-12-19 20:27:47 EST
Seems to be a parted bug. It's detecting my swap partition as 'hfs', as shown in
the original report. If I swapoff and then zero the partition, then mkswap and
swapon again, parted no longer reports it as hfs; it reports it as swap.
Comment 8 David Woodhouse 2006-02-21 10:23:05 EST
Hm, no. Another rawhide install gave me a yaboot.conf saying
'boot=/dev/sda2 /dev/sda4' and turned my swap partition into HFS again.
Comment 9 David Woodhouse 2006-03-04 19:03:35 EST
Still happening in FC5t3.
Comment 10 Paul Nasrat 2006-07-11 16:26:38 EDT
Fixed in booty 0.78-1

Python keeps target list after for loop so we were getting duplicate entries. 
This reworks the logic so we avoid that.        

http://docs.python.org/ref/for.html

Note You need to log in before you can comment on or make changes to this bug.