Bug 1760438 - AioResultList segfaults in Get/PutObj requests
Summary: AioResultList segfaults in Get/PutObj requests
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RGW
Version: 4.0
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: rc
: 4.0
Assignee: Casey Bodley
QA Contact: Tejas
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-10-10 14:33 UTC by Casey Bodley
Modified: 2020-01-31 12:47 UTC (History)
7 users (show)

Fixed In Version: ceph-14.2.4-8.el8cp, ceph-14.2.4-2.el7cp
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-31 12:47:33 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Ceph Project Bug Tracker 39660 0 None None None 2019-10-10 14:33:20 UTC
Red Hat Product Errata RHBA-2020:0312 0 None None None 2020-01-31 12:47:53 UTC

Description Casey Bodley 2019-10-10 14:33:21 UTC
Description of problem:

A data race between a frontend thread and the librados completion thread can corrupt the AioResultList and lead to segfaults. This can happen in both GET Object and PUT Object requests. Crashes reproduce more often under heavy load.


Version-Release number of selected component (if applicable): RHCS 4.0


How reproducible:

Hard to reproduce without heavy read/write workload.

Comment 1 RHEL Program Management 2019-10-10 14:33:28 UTC
Please specify the severity of this bug. Severity is defined here:
https://bugzilla.redhat.com/page.cgi?id=fields.html#bug_severity.

Comment 8 errata-xmlrpc 2020-01-31 12:47:33 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0312


Note You need to log in before you can comment on or make changes to this bug.