Bug 176046 - X on radeon 9250 crashes with kernel > 2.6.14-1.1756_FC5 (x86_64)
X on radeon 9250 crashes with kernel > 2.6.14-1.1756_FC5 (x86_64)
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-18 06:46 EST by Hans de Goede
Modified: 2015-01-04 17:23 EST (History)
3 users (show)

See Also:
Fixed In Version: 2.6.15-1.1819_FC5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-04 06:18:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hans de Goede 2005-12-18 06:46:55 EST
Description of problem:
Starting X results in a black monitor and an otherwise unresponsive PC (keyboard
dead, powerswitch only works if pressed > 4 seconds)

Version-Release number of selected component (if applicable):
I've seen this with 2.6.14-1.1770_FC5 and 2.6.14-1.1771_FC5, 2.6.14-1.1756_FC5
works fine. This is an fully up2date rawhide system.

How reproducible: 
Start X with an radeon 9250/9200pro on x86_64, dunno if this affects i386 too, I
didn't try.
Comment 1 Dave Jones 2005-12-19 23:37:41 EST
any chance you can hook up a serial console ?
otherwise, the best hope we have of capturing any panic data from this is by
hitting ctrl-alt-f1 as X is starting up, and hope that the screen resyncs back
to the console before it blows up.
Comment 2 Hans de Goede 2005-12-24 10:44:21 EST
Hi'

I've been quiet for a while because it took me some time to make the time to
test some stuff. On the xorg mailing list some ati radeon patches have been
floating around which fix a couple of radeon crashes. A fedora user has made an
SRPM with these patches:
http://www.erwinrol.com/downloads/software/xorg-x11-drv-ati-6.5.7-2.src.rpm

Unfortunatly an rpm --rebuild for this driver doesnot work for me at all. This
may be 64bit related, or just maybe my card. So I'm back to the latest Fedora
driver. This still has the same issue with the latest rawhide kernel:
kernel-2.6.14-1.1783_FC5.x86_64

I'll see if your switch to console trick works, or otherwise I'll try to borrow
a laptop to use as serial console. What do I need todo to enable a serial console?

Comment 3 Dave Jones 2005-12-24 15:47:58 EST
serial console is pretty easy to set up. (I really should document debugging
tricks like this someplace).

on the laptop, run minicom, and set the speed to 38400 (ctrl-A Z, P, G)
on the box you're testing, add to the boot command line the options..

console=ttyS0,38400 console=tty0

and you should see the kernel messages appear in minicom.
Comment 4 Michal Jaegermann 2005-12-26 18:11:52 EST
https://bugs.freedesktop.org/show_bug.cgi?id=5104 looks like related.
I see that on x86_64 too but comments in a quoted bug would suggest
that this is not hardware, or even OS, dependent.  A card I am using is
Radeon 9500 but a reporter has Radeon 7000 VE QY.

I have this problem from the time of a switch to "modular X"; does not matter
which kernel.  Turning off dri in X configuration file makes for a working,
if slow, X server.
Comment 5 Hans de Goede 2005-12-27 04:28:36 EST
That bug is most likely not related at all, that is about an r300 card and I
have an r200 card, also for me the bug only occurs with newer kernels.
Comment 6 Dave Jones 2005-12-27 17:40:39 EST
turning off dri also makes no difference to 2D speed at all, so unless you're
using some fancy 3D window manager, you should notice no difference in desktop
performance.
Comment 7 Michal Jaegermann 2005-12-27 23:37:43 EST
> turning off dri also makes no difference to 2D speed at all ...

Well, I tried ppracer and it was absolutely unusable. :-) There are
other things you may want to try.  Say, FlightGear.
Comment 8 Hans de Goede 2006-01-04 06:18:01 EST
I'm happy to report that this is fixed with kernel-2.6.15-1.1819_FC5.x86_64,
closing.
Comment 9 Michal Jaegermann 2006-02-06 19:13:32 EST
I can turn on dri with xorg-x11-drv-ati-6.5.7.3-3 and it does not crash and it
reports "(II) RADEON(0): Direct rendering enabled".  I think that this is
a question of a new driver and not of a particular kernel.

This brings to light problems with GLX but this is another story.

Note You need to log in before you can comment on or make changes to this bug.