Bug 176050 - KDS monitor not detected correctly during install
KDS monitor not detected correctly during install
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kudzu (Show other bugs)
5
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks: FC5Target
  Show dependency treegraph
 
Reported: 2005-12-18 08:23 EST by Mike Chambers
Modified: 2014-03-16 22:57 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-17 14:45:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Chambers 2005-12-18 08:23:05 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20051215 Fedora/1.7.12-3

Description of problem:
Monitor is dected as a PTS03e5 instead of the KDS XF-9b.  I think I had opened one of these up, back in the day Fedora started or something similar, but I couldn't find the bug.  So I am going to attach the .inf file to it, if I can find it or get it.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Start install
2.
3.
  

Actual Results:  Monitor detected as PTS03e5

Expected Results:  Monitor detected as KDS XF-9b

Additional info:
Comment 1 Bill Nottingham 2005-12-19 14:22:18 EST
Korea Data Systems; KDS XFlat XF-9b/XF-9c/XF-9e/XF-9p; PTS03E5; 30.0-98.0;
50.0-160.0


The PTS03e5 DDC id *is* a KDS XF-9b.

Where in the UI are you seeing it reported as PTS03e5?
Comment 2 Mike Chambers 2005-12-19 16:41:37 EST
Rigth when the installer detects video/monitor (I believe before ananconda image
starts) and that is what is shown when firstboot comes up.

I can tell a big difference during the Gnome splash screen when switching from
the picked monitor, to the xf 9b one.  So there seems to be a difference or
something, at least.
Comment 3 Chris Lumens 2005-12-20 10:55:34 EST
What are the results of running /usr/sbin/ddcprobe --monitor from a console?
Comment 4 Mike Chambers 2005-12-20 18:23:27 EST
[root@scrappy ~]# /usr/sbin/ddcprobe --monitor

Monitor autoprobe results
ID: PTS03e5
Horizontal Sync (kHZ): 30-98
Vertical Sync (HZ)  : 50-160
Width (mm): 360
Height(mm): 260

Here is a URL to the monitor specs to compare against what the ID shows..

http://www.kdsusa.com/ProductDetails.asp?prod=233
Comment 5 Chris Lumens 2005-12-21 11:29:13 EST
It's being reported as PTS03e5 instead of KDS XF-9b because we're not getting
back any Name from kudzu.  I don't see what performance difference it should
make in rhpxl what it's called as long as the sync and sizes are right (the
syncs are very close to the specs listed on the website, at least).

Bill - any thoughts?
Comment 6 Bill Nottingham 2005-12-21 11:34:41 EST
Hm, it *should* be trying to pull the monitor name from monitorsdb. I'll look at
the code.
Comment 7 Bill Nottingham 2005-12-21 20:46:41 EST
What's the output of 'kudzu -p -b ddc'?
Comment 8 Mike Chambers 2005-12-21 22:50:31 EST
[root@scrappy ~]# kudzu -p -b ddc
-
class: VIDEO
bus: DDC
detached: 0
desc: "ATI Technologies Inc. V250"
mem: 131072
-
class: MONITOR
bus: DDC
detached: 0
desc: "(null)"
id: PTS03e5
horizSyncMin: 30
horizSyncMax: 98
vertRefreshMin: 50
vertRefreshMax: 160
mode: 640x480
mode: 640x480
mode: 800x600
mode: 800x600
mode: 1024x768
mode: 1280x1024
mode: 1600x1200
mode: 640x480
Comment 9 Mike Chambers 2005-12-21 22:53:48 EST
I didn't change that, or at least not on purpose, so I changed it back to
needinfo, sorry.
Comment 10 Chris Lumens 2006-02-01 12:00:42 EST
When you reply to a bug in the NEEDINFO state, it automatically gets set back to
ASSIGNED as a way of letting us know that the information has been supplied.

Note You need to log in before you can comment on or make changes to this bug.