Bug 1760536 - The kubelet exe is not being copied to the same directory as the rest of the required wmcb files
Summary: The kubelet exe is not being copied to the same directory as the rest of the ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Windows Containers
Version: 4.3.0
Hardware: All
OS: All
unspecified
low
Target Milestone: ---
: 4.4.0
Assignee: Sebastian Soto
QA Contact: Xiaoli Tian
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-10-10 18:49 UTC by Sebastian Soto
Modified: 2020-05-13 21:52 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-13 21:52:01 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift windows-machine-config-operator pull 53 0 'None' 'closed' 'Bug 1760536: [wsu] Fixing kubelet path' 2020-04-20 14:02:35 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-13 21:52:02 UTC

Description Sebastian Soto 2019-10-10 18:49:17 UTC
Description of problem:
The kubelet is being copied to the wrong directory

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Run the wsu

Actual results:
kubelet is copied to ./tmp/kubelet.exe

Expected results:
kubelet is copied to $ANSIBLE_TEMP_DIRECTORY/kubelet.exe

Additional info:

Comment 2 gaoshang 2019-10-15 04:33:00 UTC
This bug has been verified and pass, change status to VERIFIED.

Platform: aws
Steps:
1. Create windows instance by wni
2. Configure and run wsu ansible playbook
3. Check kubelet.exe location in windows node

PS C:\Users\Administrator\AppData\Local\Temp\ansible.qehfsst3.rcz> ls


    Directory: C:\Users\Administrator\AppData\Local\Temp\ansible.qehfsst3.rcz


Mode                LastWriteTime         Length Name
----                -------------         ------ ----
d-----       10/14/2019   4:55 AM                kubernetes
-a----       10/14/2019  12:43 PM       94721095 kube.tar.gz
-a----       10/14/2019  12:43 PM      116527616 kubelet.exe
-a----       10/14/2019  12:42 PM       21458432 wmcb.exe
-a----       10/14/2019   4:55 AM          93327 worker.ign

Comment 5 errata-xmlrpc 2020-05-13 21:52:01 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.