Bug 176054 - ipw2200 associates and gets IP, but no network
Summary: ipw2200 associates and gets IP, but no network
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: rawhide
Hardware: i686
OS: Linux
medium
high
Target Milestone: ---
Assignee: John W. Linville
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-12-18 15:04 UTC by Horst H. von Brand
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2005-12-20 20:21:14 UTC


Attachments (Terms of Use)

Description Horst H. von Brand 2005-12-18 15:04:25 UTC
Description of problem:
Against a Linksys WRT54G wireless router, with the stock kernel from Linus it
works fine (that's what I'm using right now)

Version-Release number of selected component (if applicable):
kernel-2.6.14-1.1770_FC5

How reproducible:
Always


Steps to Reproduce:
1. boot
2. ifup eth1
3.
  
Actual results:
Get IP, but no network at all (not even to the router)

Expected results:
Working network

Additional info:

Comment 1 Dave Jones 2005-12-20 04:44:25 UTC
*boggle*.  There's no networking or ipw related patches in current rawhide, so
this is a mystery.

Any interesting debug info in dmesg ?

Was your build with the rawhide gcc4.1 ? With CONFIG_OPTIMIZE_FOR_SIZE ?

Comment 2 Horst H. von Brand 2005-12-20 17:21:48 UTC
Yes, very strange. 

Didn't look at dmesg, sorry.

I used the stock rawhide kernel du jour, which suddenly broke on me. By now,
that kernel is long gone here :-(

Yes, the vanilla kernel was build with rawhide's gcc, not optimizing for size. 

Haven't tried newer kernels with the wireless network, so I can't tell if they
break. Will check later today.

Comment 3 Horst H. von Brand 2005-12-20 20:21:14 UTC
OK, tried now with 2.6.14-1.1776_FC5. No problems.

Sorry for the noise.


Note You need to log in before you can comment on or make changes to this bug.