Bug 1760580 - catalog list components doesn't list out component of a specified namespace
Summary: catalog list components doesn't list out component of a specified namespace
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: odo
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
low
unspecified
Target Milestone: ---
: ---
Assignee: Tomáš Král
QA Contact: Amit
Yana Hontyk
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-10-10 21:13 UTC by Yana Hontyk
Modified: 2019-12-13 09:58 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-12-13 09:58:49 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift odo issues 2065 'None' 'open' 'catalog list components doesn''t list out component of a specified namespace' 2019-12-02 07:21:22 UTC

Description Yana Hontyk 2019-10-10 21:13:44 UTC
Description of problem:
catalog list components doesn't list out component of a specified namespace 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. $ odo project create test
2. $ oc apply -n test -f https://raw.githubusercontent.com/openshift/library/master/arch/x86_64/community/wildfly/imagestreams/wildfly-centos7.json
3. $ odo catalog list components --project test
Error: unknown flag: --project
Usage:
  odo catalog list components [flags]
[...]

Actual results:
--project flag is not supported.

Expected results:
Should list out wildfly component

Additional info:

Comment 1 Tomáš Král 2019-12-13 09:58:49 UTC
this is a feature request not a bug


Note You need to log in before you can comment on or make changes to this bug.