Bug 176066 - rhythmbox crashes when quitting
rhythmbox crashes when quitting
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: rhythmbox (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: John (J5) Palmieri
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-18 18:41 EST by Ian Burrell
Modified: 2013-03-13 00:49 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-30 11:13:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ian Burrell 2005-12-18 18:41:38 EST
Description of problem:

rhythmbox crashes when quitting even when quit immediately after starting
without playing anything.

Version-Release number of selected component (if applicable):

rhythmbox-0.9.2-3.1.x86_64

How reproducible:

Every time.

Steps to Reproduce:
1. Open rhythmbox
2. Quit rhythmbox
3. Crash
  
Additional info:

There is a bug in gnome bugzilla,
http://bugzilla.gnome.org/show_bug.cgi?id=323668, which could be similar but the
detail page is not returning.

Stderr:

*** glibc detected *** /usr/bin/rhythmbox: munmap_chunk(): invalid pointer:
0x00000000008f0800 ***
======= Backtrace: =========
/lib64/libc.so.6(__libc_free+0x189)[0x330496bee9]
/usr/bin/rhythmbox[0x43be9d]
/usr/lib64/libgobject-2.0.so.0(g_object_unref+0x10f)[0x3306a0c687]
/usr/bin/rhythmbox[0x42a755]
/usr/lib64/libgobject-2.0.so.0(g_object_unref+0x10f)[0x3306a0c687]
/usr/lib64/libgobject-2.0.so.0(g_closure_invoke+0x150)[0x3306a0ad24]
/usr/lib64/libgobject-2.0.so.0[0x3306a1a1da]
/usr/lib64/libgobject-2.0.so.0(g_signal_emit_valist+0x5e1)[0x3306a1b264]
/usr/lib64/libgobject-2.0.so.0(g_signal_emit+0x83)[0x3306a1b68d]
/usr/lib64/libgtk-x11-2.0.so.0[0x320efd6dc7]
/usr/lib64/libgtk-x11-2.0.so.0(gtk_main_do_event+0x3cc)[0x320ef0b963]
/usr/lib64/libgdk-x11-2.0.so.0[0x320f44267f]
/usr/lib64/libglib-2.0.so.0(g_main_context_dispatch+0x1ac)[0x3305c24ba1]
/usr/lib64/libglib-2.0.so.0[0x3305c278be]
/usr/lib64/libglib-2.0.so.0(g_main_loop_run+0x1a0)[0x3305c27c10]
/usr/lib64/libbonobo-2.so.0(bonobo_main+0x46)[0x330b42c904]
/usr/bin/rhythmbox(main+0x901)[0x425c89]
/lib64/libc.so.6(__libc_start_main+0xef)[0x330491ce9f]
/usr/bin/rhythmbox[0x425279]

Stack trace from bug buddy:

Backtrace was generated from '/usr/bin/rhythmbox'

Using host libthread_db library "/lib64/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread 46912496343680 (LWP 29881)]
[New Thread 1084496224 (LWP 29883)]
[New Thread 1084229984 (LWP 29882)]
0x0000003304e0c139 in __libc_waitpid (pid=29888, stat_loc=0x7fffffbec5dc, options=0)
    at ../sysdeps/unix/sysv/linux/waitpid.c:41
41	  int result = INLINE_SYSCALL (wait4, 4, pid, stat_loc, options, NULL);
#0  0x0000003304e0c139 in __libc_waitpid (pid=29888, stat_loc=0x7fffffbec5dc,
options=0)
    at ../sysdeps/unix/sysv/linux/waitpid.c:41
#1  0x00000032100526d9 in libgnomeui_segv_handle (signum=6) at gnome-ui-init.c:786
#2  <signal handler called>
#3  0x000000330492fbf0 in *__GI_raise (sig=) at
../nptl/sysdeps/unix/sysv/linux/raise.c:67
#4  0x0000003304930f20 in *__GI_abort () at ../sysdeps/generic/abort.c:88
#5  0x0000003304965a5f in __libc_message (do_abort=) at
../sysdeps/unix/sysv/linux/libc_fatal.c:170
#6  0x000000330496bee9 in *__GI___libc_free (mem=) at malloc.c:5603
#7  0x000000000043be9d in rb_audioscrobbler_finalize (object=) at
rb-audioscrobbler.c:345
#8  0x0000003306a0c687 in IA__g_object_unref (_object=) at gobject.c:1745
#9  0x000000000042a755 in rb_shell_finalize (object=) at rb-shell.c:759
#10 0x0000003306a0c687 in IA__g_object_unref (_object=) at gobject.c:1745
#11 0x0000003306a0ad24 in IA__g_closure_invoke (closure=0x8406a0,
return_value=0x7fffffbed710, n_param_values=2, 
    param_values=0x7fffffbed820, invocation_hint=0x7fffffbed6d0) at gclosure.c:187
#12 0x0000003306a1a1da in signal_emit_unlocked_R (node=0x7e3260, detail=0,
instance=0x86b580, 
    emission_return=0x7fffffbeda00, instance_and_params=0x7fffffbed820) at
gsignal.c:2449
#13 0x0000003306a1b264 in IA__g_signal_emit_valist (instance=0x86b580,
signal_id=) at gsignal.c:2218
#14 0x0000003306a1b68d in IA__g_signal_emit (instance=) at gsignal.c:2252
#15 0x000000320efd6dc7 in gtk_widget_event_internal (widget=0x86b580,
event=0x920850) at gtkwidget.c:3735
#16 0x000000320ef0b963 in IA__gtk_main_do_event (event=0x920850) at gtkmain.c:1346
#17 0x000000320f44267f in gdk_event_dispatch (source=) at gdkevents-x11.c:2291
#18 0x0000003305c24ba1 in IA__g_main_context_dispatch (context=0x7c57c0) at
gmain.c:1913
#19 0x0000003305c278be in g_main_context_iterate (context=0x7c57c0, block=1,
dispatch=1, self=) at gmain.c:2544
#20 0x0000003305c27c10 in IA__g_main_loop_run (loop=0xf5bbd0) at gmain.c:2748
#21 0x000000330b42c904 in bonobo_main () at bonobo-main.c:312
#22 0x0000000000425c89 in main (argc=1, argv=0x7fffffbee438) at main.c:381

Thread 3 (Thread 1084229984 (LWP 29882)):
#0  0x0000003304e08c57 in ?? () from /lib64/libpthread.so.0
No symbol table info available.
#1  0x00000033082020e0 in g_cond_timed_wait_posix_impl (cond=) at
gthread-posix.c:229
	result = 
Thread 2 (Thread 1084496224 (LWP 29883)):
#0  0x00000033049c2a90 in *__GI___poll (fds=0x83ed40, nfds=9, timeout=-1) at
../sysdeps/unix/sysv/linux/poll.c:86
	oldtype = 0
	result = 
Thread 1 (Thread 46912496343680 (LWP 29881)):
#0  0x0000003304e0c139 in __libc_waitpid (pid=29888, stat_loc=0x7fffffbec5dc,
options=0)
    at ../sysdeps/unix/sysv/linux/waitpid.c:41
	oldtype = 0
	result =
Comment 1 James "Doc" Livingston 2006-01-12 01:14:08 EST
This bug has been fixed in Rhythmbox cvs:
http://cvs.gnome.org/viewcvs/rhythmbox/shell/rb-audioscrobbler.c?r1=1.6&r2=1.7
Comment 2 Ian Burrell 2006-01-29 18:01:05 EST
This bug hasn't been a problem since rhythmbox-0.9.2.cvs20060123-1.x86_64 was
installed.

Note You need to log in before you can comment on or make changes to this bug.