Bug 176067 - Repackage to create firefox-devel package with development files
Repackage to create firefox-devel package with development files
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-18 19:13 EST by Sindre Pedersen Bjørdal
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-18 19:32:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sindre Pedersen Bjørdal 2005-12-18 19:13:20 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20051018 Epiphany/1.9.2

Description of problem:
This is a request for a repackage of firefox to include development files in a firefox-devel package. These files are needed if one would want to build stuff against the firefox 1.5 gecko instead of using the seamonkey gecko. The two are different, and including these files would allow packages of applications that use gtkmozembed without depending on the huge, and depreciated seamonkey package, as well as applications such as epiphany to take use of the new features of firefox 1.5, like the new back-forward cache. 

Ubuntu has a firefox-devel package, it includes the following files: 

%{_libdir}/pkgconfig/*.pc
%{_datadir}/idl/mozilla-firefox 
%{_includedir}/mozilla-firefox 
%{_bindir}/firefox-config 

The current firefox package does not include these files at all. 

Version-Release number of selected component (if applicable):
firefox-1.5-1.1

How reproducible:
Always

Steps to Reproduce:
1

Additional info:
Comment 1 Christopher Aillon 2005-12-18 19:32:26 EST
I'm a bit surprised you would call seamonkey huge but want firefox-devel for the
bfcache (which adds much more bloat to a browser instance than seamonkey).

That said, firefox-devel is sorta nice but it doesn't add *that much* in the
grand scheme of things.  It is not really that stable and will force developers
to change APIs twice (once now and then again when we move to XULrunner.  See
http://wiki.mozilla.org/XUL:Xul_Runner for more).

Wontfix since we want to package up XULrunner as the development kit.

Note You need to log in before you can comment on or make changes to this bug.