Bug 1760810 - admin console overview sidebar showing wrong resources when serverless installed
Summary: admin console overview sidebar showing wrong resources when serverless installed
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
: 4.3.0
Assignee: cvogt
QA Contact: Ruchir Garg
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-10-11 11:47 UTC by spathak@redhat.com
Modified: 2020-01-23 11:07 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: In Overview, we are consuming sidebar resources via extension utils and first check is if knative CRDs are present then check is based on the key as in knative specific resources "configurations" and in current code, issue was even if knative resources were not present but utils returned { configurations: [] }. The non-admin user won't even be able to view workloads under-console as firehose fetches knative specific resources and results in 403 Consequence: For kubeadmin in case of normal deployments and as in sidebar it identifies configurations and knative operator is installed so treated it as knative resource i.e configurations, Revisions, routes. For the non-admin user, it shows Permission issue if user tries to view workloads in console Fix: with added check in case of no configurations found will return undefined, so will not add any knative specific resources in overviewitems. For fetching resources via firehose add key "option:true" to make it non required Result: Overview sidebar resources work as expected in case of normal deployment and knative specific deployment. A non-admin user can view the workloads.
Clone Of:
Environment:
Last Closed: 2020-01-23 11:07:15 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:0062 None None None 2020-01-23 11:07:40 UTC

Description spathak@redhat.com 2019-10-11 11:47:38 UTC
Description of problem:
Even though the deployment selected in the workloads view is not a knative workload, the sidebar is showing the resource list for knative resources.

This can be observed by going to the openshift-console project -> workloads tab. Then click on the first deployment.  This is working correctly in dev console topology.


How reproducible:


Steps to Reproduce:
1.Login as non-admin in console go to projects
2.Click on workloads
3.Click on the first deployment

Actual results:
No services, no routes, no pods for non-serverless workload

Expected results:
Service, routes, pods information should be shown

Additional info:

Comment 1 cvogt 2019-11-05 15:16:00 UTC
Fixed by https://bugzilla.redhat.com/show_bug.cgi?id=1758628

Comment 3 errata-xmlrpc 2020-01-23 11:07:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0062


Note You need to log in before you can comment on or make changes to this bug.