Bug 17611 - EFI partitions are type 0xEF
EFI partitions are type 0xEF
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Florence Beta-3
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-09-18 13:02 EDT by Matt Domsch
Modified: 2008-05-01 11:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-01 18:11:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Domsch 2000-09-18 13:02:55 EDT
Anaconda, fdisk, etc. need to know that EFI partitions are type 0xEF, and 
have FAT16 or FAT32 file systems.
Comment 1 Michael Fulbright 2001-01-11 12:10:08 EST
Is this referring to the /boot/efi partition?  This would require substantial
changes to how we allocate partitions, and seems to work as it is currently setup.
Comment 2 Matt Domsch 2001-01-11 12:28:14 EST
Yes, /boot/efi is the EFI System Partition.  Per the EFI spec, it carries a DOS 
type of 0xef to distinguish it from type 0x6.  May not be critical, as 0x6 does 
indeed work today.
Comment 3 Glen Foster 2001-01-11 16:16:20 EST
This defect is considered MUST-FIX for Florence Gold release
Comment 4 Michael Fulbright 2001-01-17 12:33:43 EST
Will defer this for now since it appears to work.
Comment 5 Matt Domsch 2001-04-30 17:05:04 EDT
I'm re-opening this for consideration again now that the IA-32 release is 
finished.
Comment 6 Bill Nottingham 2001-04-30 17:36:17 EDT
FWIW, one of the partition types (6, I believe) doesn't work at all on
the Compaq box here. EFI never sees it... (this could be a bug in their
smartarray EFI driver, though.)
Comment 7 Bill Nottingham 2001-05-01 18:11:32 EDT
OK, this is fixed in CVS. It should be in the next build.

Note You need to log in before you can comment on or make changes to this bug.