Bug 1761234 - scanimage doesn't list Canon LiDE 110 scanner anymore even though sane-find-scanner lists it
Summary: scanimage doesn't list Canon LiDE 110 scanner anymore even though sane-find-s...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: sane-backends
Version: 30
Hardware: Unspecified
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Nils Philippsen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-10-13 15:36 UTC by J. Thiem
Modified: 2019-10-19 17:41 UTC (History)
3 users (show)

Fixed In Version: sane-backends-1.0.28-4.fc30
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-19 17:41:47 UTC


Attachments (Terms of Use)

Description J. Thiem 2019-10-13 15:36:53 UTC
Description of problem:

scanimage doesn't list Canon LiDE 110 scanner anymore even though sane-find-scanner lists it:

$ sane-find-scanner 

  # sane-find-scanner will now attempt to detect your scanner. If the
  # result is different from what you expected, first make sure your
  # scanner is powered up and properly connected to your computer.

  # No SCSI scanners found. If you expected something different, make sure that
  # you have loaded a kernel SCSI driver for your SCSI adapter.

could not open USB device 0x1d6b/0x0003 at 002:001: Access denied (insufficient permissions)
could not open USB device 0x138a/0x0090 at 001:005: Access denied (insufficient permissions)
could not open USB device 0x13d3/0x5248 at 001:004: Access denied (insufficient permissions)
could not open USB device 0x046d/0xc077 at 001:009: Access denied (insufficient permissions)
could not open USB device 0x056a/0x5047 at 001:006: Access denied (insufficient permissions)
found USB scanner (vendor=0x04a9 [Canon], product=0x1909 [CanoScan], chip=GL124) at libusb:001:007
could not open USB device 0x1d6b/0x0002 at 001:001: Access denied (insufficient permissions)
  # Your USB scanner was (probably) detected. It may or may not be supported by
  # SANE. Try scanimage -L and read the backend's manpage.

  # Not checking for parallel port scanners.

  # Most Scanners connected to the parallel port or other proprietary ports
  # can't be detected by this program.

  # You may want to run this program as root to find all devices. Once you
  # found the scanner devices, be sure to adjust access permissions as
  # necessary.
$ scanimage -L
device `v4l:/dev/video0' is a Noname Integrated Camera: Integrated C virtual device
$

I used this scanner with simple-scan on this very same install a month ago, so the driver should work. Now neither simple-scan nor scan-image list it anymore. (Was the driver taken out with a recent kernel update or something?)

Version-Release number of selected component (if applicable):
scanimage (sane-backends) 1.0.28; backend version 1.0.28

How reproducible:
100%

Steps to Reproduce:
1. Plug in Canon LIDE 110
2. Run scan-find-scanner which lists scanner
3. Run scanimage -L which doesn't
3. Open simple-scan which also no longer lists it

Actual results:
in the actual scanning programs scanimage and simple-scan I can no longer use the scanner

Expected results:
scanner is still available

Additional info:
I renamed my user recently with usermod -l, which might or might not be related. However, sudo'ing scanimage does nothing and my new user is in the "lp" group, so I'm not sure what permissions are off if any

Comment 1 Zdenek Dohnal 2019-10-14 13:24:26 UTC
Hi,

thank you for reporting the issue!

Actually it is caused by missing genesys backend in sane-backends as whole, who took care of this type of scanners.

Genesys backend is now written in C++11 and it cannot be built without it due settings during configure phase. Buildroot did not have gcc-c++ during build and configure produced only warning about genesys will not be created.

Adding gcc-c++ to buildrequires fixes it.

Would you mind trying this build if it fixes it? https://koji.fedoraproject.org/koji/taskinfo?taskID=38290736

Comment 2 J. Thiem 2019-10-14 17:52:33 UTC
Ok so I tested the build you linked above, and the scanner is listed now but attempting a scan appears to crash:

$ scanimage -L
device `v4l:/dev/video0' is a Noname Integrated Camera: Integrated C virtual device
device `genesys:libusb:001:020' is a Canon LiDE 110 flatbed scanner
$ scanimage --format=jpeg --device-name=genesys:libusb:001:020 -o ./img.jpeg
/usr/include/c++/9/bits/stl_vector.h:1042: std::vector<_Tp, _Alloc>::reference std::vector<_Tp, _Alloc>::operator[](std::vector<_Tp, _Alloc>::size_type) [with _Tp = short unsigned int; _Alloc = std::allocator<short unsigned int>; std::vector<_Tp, _Alloc>::reference = short unsigned int&; std::vector<_Tp, _Alloc>::size_type = long unsigned int]: Assertion '__builtin_expect(__n < this->size(), true)' failed.
Aborted (core dumped)
$

Comment 3 J. Thiem 2019-10-17 11:41:35 UTC
https://koji.fedoraproject.org/koji/taskinfo?taskID=38324885 This build fixes things for me!

Comment 4 Fedora Update System 2019-10-17 12:56:20 UTC
FEDORA-2019-4c80d8cf5f has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-4c80d8cf5f

Comment 5 Fedora Update System 2019-10-17 23:42:19 UTC
sane-backends-1.0.28-3.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-4c80d8cf5f

Comment 6 Fedora Update System 2019-10-18 08:52:13 UTC
FEDORA-2019-4e0ac1c8bb has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-4e0ac1c8bb

Comment 7 Fedora Update System 2019-10-18 21:00:15 UTC
sane-backends-1.0.28-4.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-4e0ac1c8bb

Comment 8 Fedora Update System 2019-10-19 17:41:47 UTC
sane-backends-1.0.28-4.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.