Bug 176124 - [RHEL4] LDAP addressbook authentication setting changes require a restart to take effect
[RHEL4] LDAP addressbook authentication setting changes require a restart to ...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: evolution (Show other bugs)
4.0
All Linux
low Severity medium
: ---
: ---
Assigned To: Matthew Barnes
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-19 12:19 EST by Suzanne Hillman
Modified: 2008-02-03 11:29 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-03 11:29:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 261783 None None None Never

  None (edit)
Description Suzanne Hillman 2005-12-19 12:19:31 EST
Description of problem:
"Error loading addressbook.

We were unable to open this addressbook.  This either means you have entered an
incorrect URI, or the LDAP server is unreachable."

Any time I try to click on the LDAP address book entry, and I cannot use the
address book when trying to address a new mail message.

The address book details are as per the RHEL4 instructions at
http://intranet.corp.redhat.com/ic/intranet/AccessingRedHatRosterInEvolution.html
(I tried both the Never and Always options for SSL).

I'm utterly baffled, since I'm certain I tested this with the previous RHEL4 U3
tree, which had the same version of Evo, and this worked then.

Version-Release number of selected component (if applicable):
evolution-2.0.2-25

How reproducible:
At least on this machine, always. But there isn't another LDAP server to test
with...

Steps to Reproduce:
1. Try to set up LDAP server as per the RHEL4 instructions at
http://intranet.corp.redhat.com/ic/intranet/AccessingRedHatRosterInEvolution.html
2. click on it once it's finished.
3. Try to search on it, to address a new email message
  
Actual results:
It's give an error as above, and it won't be able to search on it.

Expected results:
No error, and searching via new mail message addressing should work.

Additional info:
The only thing I'm aware of which is different on this machine from the last
tree's testing is that I'm using the SMP kernel now, because it works (and did
not before).
Comment 1 Suzanne Hillman 2005-12-19 12:20:30 EST
Putting as specific to x86_64 for now (viper, specifically), until it gets
tested on an i386.
Comment 2 Nalin Dahyabhai 2005-12-19 16:09:52 EST
Suzanne, we appear to have several servers scattered around our network.  I try
to keep
http://intranet.corp.redhat.com/ic/intranet/NetworkClientConfiguration.html
reasonably up to date, and (in case it helps) have just updated the list of
directory servers noted there.
Comment 3 Suzanne Hillman 2005-12-19 16:12:19 EST
Nalin - thanks. I asked others, and the one I was testing with appeared to work
for other people. So it's not the server.

However, I shall copy that link for later knowledge!
Comment 4 Dave Malcolm 2005-12-19 18:35:09 EST
Can you give me access to the client machine where this is failing?
Comment 5 Dave Malcolm 2005-12-19 19:13:31 EST
Please can you: 
(i) give more detail in step 3.
(ii) the result of running:
rpm -q --queryformat "%{NAME}-%{VERSION}-%{RELEASE}.%{ARCH}\n" evolution
evolution-data-server openldap

I can successfully connect to that server using RHEL4 U2 on x86_64 on one of my
test boxes, by doing a search in the Contacts component.

This is with U2:
evolution-2.0.2-22.x86_64
evolution-data-server-1.0.2-9.x86_64
openldap-2.2.13-3.i386
openldap-2.2.13-3.x86_64

Latest for U3 is evolution-2.0.2-25.x86_64
(e-d-s hasn't upgraded)
openldap has bumped from 2.2.13-3 to 2.2.13-4 in a post-U2 errata

Tried upgrading just evolution; addressbook search within Contacts component
still works; this is with:
evolution-2.0.2-25.x86_64
evolution-data-server-1.0.2-9.x86_64
openldap-2.2.13-3.i386
openldap-2.2.13-3.x86_64

(doing an "evolution --force-shutdown" after each upgrade, to ensure we don't
have a stale e-d-s process in memory)

Tried upgrading openldap, and it still works, this is with:
evolution-2.0.2-25.x86_64
evolution-data-server-1.0.2-9.x86_64
openldap-2.2.13-4.i386
openldap-2.2.13-4.x86_64
Comment 6 Dave Malcolm 2005-12-19 19:21:28 EST
I guess I really just need access to that machine to try to debug what the
problem is and its extent.

BTW, if you run 
  evolution --force-shutdown
then manually start
  /usr/libexec/evolution-data-server-1.0
at a terminal, then start evolution, you should see extensive LDAP debug
information.

Comment 8 Dave Malcolm 2005-12-20 11:52:44 EST
You had "Use Secure Password: Always"; should be "Never".
I changed it to "Never" and it continued to fail; I needed to restart the
evolution-data-server process before it would work (it now works on that machine).

So the bug is that you need to restart e-d-s before that change takes effect.

(I believe that this is not a regression)

Comment 9 Suzanne Hillman 2005-12-20 13:07:43 EST
Ah. I thought I had tried restarting with both Always and with Never, but noted!
Should I leave this open to stand in for the bug relating to needing to restart,
or not?

As for regression, I thought that I did not have to restart evo in order to get
it to work, but I'm not positive. For now, removing regression label.
Comment 10 Dave Malcolm 2005-12-20 15:14:13 EST
If you have to restart a user-level application for a change in settings to take
effect, then that should be clearly labelled in the UI (or else it's a bug). 
The only case I can think of is in evolution-connector, where it explicitly
warns you to restart.

So I think this bug should be renamed to "LDAP addressbook authentication
setting changes require a restart to take effect"
Comment 11 Dave Malcolm 2005-12-20 15:17:52 EST
I just reproduced this on a RHEL4 U2-ish box:
evolution-2.0.2-22
evolution-data-server-1.0.2-9.fix169497.1

so I'm fairly sure this is not a regression.
Comment 12 Dave Malcolm 2005-12-20 15:18:21 EST
(and this was on a VMware i386 instance)
Comment 13 Dave Malcolm 2005-12-20 15:32:43 EST
Problem still affects rawhide:
evolution-2.5.2-1
evolution-data-server-1.5.2-1
Comment 14 Dave Malcolm 2005-12-20 16:05:08 EST
Looks like a duplicate of this upstream bug:
http://bugzilla.gnome.org/show_bug.cgi?id=261783
Comment 16 Matthew Barnes 2008-02-03 11:29:31 EST
Evolution 2.0.2 is only being updated for security issues.  Closing as WONTFIX.

Note You need to log in before you can comment on or make changes to this bug.