Bug 1761346 - [Feature:Platform] Managed cluster should have no crashlooping pods in core namespaces over two minutes [Suite:openshift/conformance/parallel]
Summary: [Feature:Platform] Managed cluster should have no crashlooping pods in core n...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: apiserver-auth
Version: 4.2.0
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: ---
: 4.4.0
Assignee: Venkata Siva Teja Areti
QA Contact: scheng
URL:
Whiteboard:
Depends On:
Blocks: 1776768
TreeView+ depends on / blocked
 
Reported: 2019-10-14 08:36 UTC by ge liu
Modified: 2020-05-13 21:52 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
: 1776768 (view as bug list)
Environment:
Last Closed: 2020-05-13 21:52:09 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift origin pull 24134 'None' closed Bug 1761346: e2e: populate pending pods map everytime with most recent data 2020-04-22 17:17:26 UTC
Github openshift origin pull 24155 'None' closed Bug 1761346: e2e: populate pending pods map everytime with most recent data 2020-04-22 17:17:26 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-13 21:52:11 UTC

Description ge liu 2019-10-14 08:36:43 UTC
Description of problem:[Feature:Platform] Managed cluster should have no crashlooping pods in core namespaces over two minutes [Suite:openshift/conformance/parallel] 


Oct 13 17:05:56.695: INFO: Running AfterSuite actions on all nodes Oct 13 17:05:56.695: INFO: Running AfterSuite actions on node 1 fail [github.com/openshift/origin/test/extended/operators/cluster.go:118]: Expected <[]string | len:1, cap:1>: [ "Pod openshift-authentication/oauth-openshift-cffc48d76-dgjbm was pending entire time: unknown error", ]

Recent failures:

https://prow.svc.ci.openshift.org/view/gcs/origin-ci-test/logs/release-openshift-ocp-installer-e2e-aws-mirrors-4.2/72

Version-Release number of selected component (if applicable):
4.2

How reproducible:
Sometimes

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Standa Laznicka 2019-10-14 11:32:46 UTC
There's a bug in the test which causes that a pod that no longer exists because it's replaced by a different one from the same deployment is never removed from the slice of failing pods

Comment 6 errata-xmlrpc 2020-05-13 21:52:09 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.