Bug 176138 - Please enable Serbian translation in redhat-artwork
Please enable Serbian translation in redhat-artwork
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: redhat-artwork (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: John (J5) Palmieri
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-19 13:08 EST by Igor Miletic
Modified: 2013-03-13 00:49 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-23 09:09:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Igor Miletic 2005-12-19 13:08:21 EST
Please enable Serbian translation in redhat-artwork.

The locale(s) for Serbian are

sr_CS.UTF-8 (default, cyrillic script, available in CVS)
sr_CS.UTF-8@Latn (po files not yet available in CVS, still awaiting to be added
to ACL)

More info on these locales can be found here if needed:
http://srpski.org/locale/

The keyboard for sr_CS is "srp" in XKB. The latin locale sr_CS@Latn uses
"srp(latin)".

The timezone for Serbia and Montenegro is GMT+0100.
Comment 1 Rahul Sundaram 2006-02-20 06:20:48 EST

These bugs are being closed since a large number of updates have been released
after the FC5 test1 and test2 releases. Kindly update your system by running yum
update as root user or try out the third and final test version of FC5 being
released in a short while and verify if the bugs are still present on the system
.Reopen or file new bug reports as appropriate after confirming the presence of
this issue. Thanks
Comment 2 Miloš Komarčević 2006-02-21 04:57:04 EST
The Serbian translations (sr and sr@Latn) are still not being shipped with
redhat-artwork-0.238-1.1 in FC5test3. Please ship these translations for FC5 final.
Comment 3 John (J5) Palmieri 2006-02-21 11:23:37 EST
I'm not really sure what has to be done here.  It will have to go out as an
update as we are pretty much frozen.  Can you provide a patch which would enable
this?  
Comment 4 Igor Miletic 2006-02-21 11:27:56 EST
Basically all you need to do is to include sr.po and sr@Latn.po files in your
package. Once someone chooses Serbian as the localization, proper string will be
chosen from these files.
Comment 5 Igor Miletic 2006-02-21 12:25:34 EST
To be more specific. You would need to convert po file to mo files (my guess is
that this is automatic process, or use po2mo script), then add these files under
/usr/share/locale/sr/LC_MESSAGES/redhat-artwork.mo
and
/usr/share/locale/sr@Latn/LC_MESSAGES/redhat-artwork.mo
for sr.po and sr@Latn.po respectively. Both files are in CVS. You will notice
that neither sr nor sr@Latn direcotries exist, so you will need to create them.
Do you want them attached to this bug?

Comment 6 Miloš Komarčević 2006-02-21 12:43:33 EST
Errr, Igore, unlike other translations, redhat-artwork strings do not end up in
mo files, they are present in
/usr/share/gdm/themes/Bluecurve/GdmGreeterTheme.desktop ,
/usr/share/gdm/themes/Bluecurve/Bluecurve.xml and
/usr/share/themes/Bluecurve/index.theme

John, the redhat-artwork package maintainer should know where to add sr and
sr@Latn to the list of locales that are automatically included at build time.
Comment 7 Igor Miletic 2006-02-21 12:46:48 EST
Oops.
I guess I should have ckecked this before I wrote it.

Comment 8 Miloš Komarčević 2006-02-21 13:00:54 EST
Upon closer inspection it looks like sr.po and sr@Latn.po are not at all
included in the redhat-artwork source tarball! So you just need to pull them in
from CVS I guess... (Thought this happened automatically?!?!)
Comment 9 John (J5) Palmieri 2006-02-21 13:08:21 EST
If they are in CVS they should be in the latest packages.
Comment 10 Miloš Komarčević 2006-02-21 13:13:20 EST
John, although they _should_, they're not. They have been in CVS for months, and
have been missing from redhat-artwork for months, vene in the latest fc5test3
and rawhide packages.
Comment 11 John (J5) Palmieri 2006-02-22 14:46:20 EST
problem was they were not in all_LINGUAS in the configure.in script so they
never got added to the releases.  New packages are being rolled.
Comment 12 Miloš Komarčević 2006-02-23 07:24:10 EST
I can confirm the translations now appear in the latest Rawhide package, thanks
John. I guess the other open bugs for the packages missing our translations have
the same problem and solution...

Note You need to log in before you can comment on or make changes to this bug.