Bug 1761457 - ceph-mds get keys from monitor - gets them from non-existent mds
Summary: ceph-mds get keys from monitor - gets them from non-existent mds
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Ceph-Ansible
Version: 4.0
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: rc
: 4.0
Assignee: Guillaume Abrioux
QA Contact: Yogev Rabl
URL:
Whiteboard:
Depends On:
Blocks: 1594251
TreeView+ depends on / blocked
 
Reported: 2019-10-14 12:57 UTC by Giulio Fidente
Modified: 2020-01-31 12:47 UTC (History)
11 users (show)

Fixed In Version: ceph-ansible-4.0.2-1.el8cp
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-31 12:47:33 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github ceph ceph-ansible issues 4553 0 'None' closed ceph-mds get keys from monitor - gets them from non-existent mds 2020-03-06 08:30:33 UTC
Github ceph ceph-ansible pull 4590 0 'None' closed common: do not reset `container_exec_cmd` (bp #4564) 2020-03-06 08:30:33 UTC
Red Hat Product Errata RHBA-2020:0312 0 None None None 2020-01-31 12:47:53 UTC

Comment 1 RHEL Program Management 2019-10-14 12:57:55 UTC
Please specify the severity of this bug. Severity is defined here:
https://bugzilla.redhat.com/page.cgi?id=fields.html#bug_severity.

Comment 6 Hemanth Kumar 2020-01-07 05:24:47 UTC
Hi Giulio,

The logs mentioned in the Description is not accessible and I would like to know exactly what the issue is and how do we verify the fix ?

Thanks,
Hemanth

Comment 7 Giulio Fidente 2020-01-08 07:43:03 UTC
(In reply to Hemanth Kumar from comment #6)
> Hi Giulio,
> 
> The logs mentioned in the Description is not accessible and I would like to
> know exactly what the issue is and how do we verify the fix ?

logs might have expired, I will attach them to bug next time

the issue was only seen when mds and mon were colocated; I think that in such a scenario the container_exec_cmd fact, which is set per-node, was mistakenly updated to run within an mds container but later on the "get keys" task expected instead to run within a mon container

Comment 11 errata-xmlrpc 2020-01-31 12:47:33 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0312


Note You need to log in before you can comment on or make changes to this bug.