Bug 176152 - Please enable Serbian translation in usermode
Please enable Serbian translation in usermode
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: usermode (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jindrich Novy
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-19 13:20 EST by Igor Miletic
Modified: 2013-07-02 19:12 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-03 09:36:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Translation file for usermode (16.56 KB, text/plain)
2006-01-03 09:16 EST, Igor Miletic
no flags Details

  None (edit)
Description Igor Miletic 2005-12-19 13:20:27 EST
Please enable Serbian translation in usermode.

The locale(s) for Serbian are

sr_CS.UTF-8 (default, cyrillic script, available in CVS)
sr_CS.UTF-8@Latn (po files not yet available in CVS, still awaiting to be added
to ACL)

More info on these locales can be found here if needed:
http://srpski.org/locale/

The keyboard for sr_CS is "srp" in XKB. The latin locale sr_CS@Latn uses
"srp(latin)".

The timezone for Serbia and Montenegro is GMT+0100.
Comment 1 Jindrich Novy 2006-01-03 03:15:53 EST
I don't see the translation file sr_CS.po in the usermode/po directory. I'm not
sure whether it's actually translated. If you translated this file, could you
please send it here so that I can add it?
Comment 2 Jindrich Novy 2006-01-03 08:53:14 EST
Ok, just noticed that the sr.po was missing as well so I added it to let
usermode be translated in Serbian. The translation should work properly since
usermode-1.85.
Comment 3 Igor Miletic 2006-01-03 09:16:27 EST
Created attachment 122710 [details]
Translation file for usermode

I attached useremode.po (translation for Serbian language) in case you need it.
This is cyrillic translation (default one).
Comment 4 Jindrich Novy 2006-01-03 09:36:18 EST
Thanks, The new usermode-1.85 with the Serbian translation enabled is now built
and should appear in tomorrow's rawhide.
Comment 5 Miloš Komarčević 2006-01-05 20:50:13 EST
Jindrich, how come sr.po was missing? It has been committed to the Fedora CVS
months ago!?
Comment 6 Jindrich Novy 2006-01-06 06:26:33 EST
I see the last change Nov 7th 2005. It's a common practise to contact the
developer when new complete translation is added so that he can add it to
ALL_LINGUAS. You did so, hence I added the translation. Note there's 60 .po
files in usermode/po and most of them are translated incompletely. It's hard for
me to check what translations are ready every time I want to come with the new
upstream release.
Comment 7 Miloš Komarčević 2006-01-06 07:28:45 EST
Oh, ok, we'll do that in the future, sorry. The instructions on the Fedora
Translation Project page don't mention this, I thought CVS did that
automatically once a translation is committed (at least it seems to send an
email to a few package maintainersrs, but not all...)

Checked the contents of usermode-1.85, and the sr translations are included,
thanks. Just to give you a heads up, we'll also be committing sr@Latn.po files
as soon as translation maintainers create ACL entries for us in the CVS.
Comment 8 Jindrich Novy 2006-01-06 14:56:49 EST
Ok, the problem is that the commits only go to fedora-commit-list@ and maybe
some other same-styled list which is hard to follow. The easiest way is just to
file a bug to package maintainer (me in case of usermode) and I'll add it.
Thanks for the notice about sr@Latn.po translation. Could you post here a note
after it's committed? I'll add it in the same way as sr.po.
Comment 9 Miloš Komarčević 2006-05-19 14:00:01 EDT
sr@Latn.po has been available for a while, please add to ALL_LINGUAS at your
convenience. Sorry I forgot the reminder before the FC5 release...

Note You need to log in before you can comment on or make changes to this bug.