Bug 176159 - -devel: missing (modular) X dependancies
-devel: missing (modular) X dependancies
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kdelibs (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-19 14:09 EST by Rex Dieter
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-21 10:17:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rex Dieter 2005-12-19 14:09:37 EST
-devel: should add
Requires: xorg-x11-proto-devel
Requires: libX11-devel 
for usage of X11/X.h and X11/Xlib.h, repectively, in it's own installed headers.

These are the first ones I've found by casual inspection, there may be more.

You may want to add whatever(??) owns libICE.so, since kdelibs' .la files
include references to it, and libXt-devel (since many/most kde apps' default
./configure test for the presence ot X libs looks for libXt.so)
Comment 1 Rex Dieter 2005-12-19 14:16:47 EST
I see that libICE/libX11 is picked up by qt-devel, though arguably, libX11
should be here in kdelibs too, since it contains direct references to X11/Xlib.h
Comment 2 Ville Skyttä 2005-12-19 17:48:24 EST
(In reply to comment #0)
> and libXt-devel (since many/most kde apps' default
> ./configure test for the presence ot X libs looks for libXt.so)

FWIW, I think this alone is not a reason to make kdelibs-devel pull libXt-devel
in.  If the apps use it directly (for configure tests or whatever), they should
have a build dependency on it.
Comment 3 Rex Dieter 2005-12-21 09:12:39 EST
Re: comment #2:  No, the apps don't use libXt directly, but kde's *generic*
configure test for X includes and X libraries look for X11/Intrinsic.h and libXt
respectively.  If libXt-devel isn't added to kdelibs-devel's Req's, then
(almost?) *every* kde application will need:
BuildRequires: libXt-devel
just to build, even though they don't use it.  

OTOH, it's arguable that kde's generic test for the presence of X headers/libs
is wrong/unnecesssary.
Comment 4 Ngo Than 2005-12-21 10:17:27 EST
it seems qt needs libXt-devel for building, those requires should be added in
qt-devel. Many thanks for your reports.
Comment 5 Rex Dieter 2005-12-21 10:30:00 EST
Don't forget kdelibs-devel should have 
Requires: xorg-x11-proto-devel libX11-devel
regardless of qt-devel's situation.

Note You need to log in before you can comment on or make changes to this bug.