Bug 1761608 - After killing the ansible-runner-service container the old container remains
Summary: After killing the ansible-runner-service container the old container remains
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Ceph-Installer
Version: 4.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: 4.0
Assignee: Paul Cuzner
QA Contact: Tejas
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-10-14 21:13 UTC by Paul Cuzner
Modified: 2020-01-31 12:47 UTC (History)
6 users (show)

Fixed In Version: cockpit-ceph-installer-0.9-2.el8cp
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-31 12:47:33 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:0312 0 None None None 2020-01-31 12:47:53 UTC

Description Paul Cuzner 2019-10-14 21:13:12 UTC
Description of problem:
The cockpit-ceph-installer package provides a command to start and stop the ansible runner API. However, when using the -k option to stop the container the image is not removed, which prevents the container from being restarted.

Version-Release number of selected component (if applicable):
cockpit-ceph-installer 0.9-1

How reproducible:
every time


Steps to Reproduce:
1. run ansible-runner-service.sh -s to start the container
2. ansible-runner-service.sh -k to stop the container
3. use podman/docker to see the container image is still present

Actual results:
container is not removed

Expected results:
container should be removed by a -k operation


Additional info:

Comment 1 Paul Cuzner 2019-10-15 22:53:28 UTC
two commits address this issue d2eb86540314acecd232dd32ec78cc231f17d2cf and 292d0bf9c5a191780b60337dc6f6395faac7ce6a

Comment 5 errata-xmlrpc 2020-01-31 12:47:33 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0312


Note You need to log in before you can comment on or make changes to this bug.