Bug 1761610 - installing ansible-runner-service setup script does not create an iso directory
Summary: installing ansible-runner-service setup script does not create an iso directory
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Ceph-Installer
Version: 4.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: 4.0
Assignee: Paul Cuzner
QA Contact: Tejas
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-10-14 21:19 UTC by Paul Cuzner
Modified: 2020-01-31 12:47 UTC (History)
7 users (show)

Fixed In Version: cockpit-ceph-installer-0.9-2.el8cp
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-31 12:47:36 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:0312 0 None None None 2020-01-31 12:47:46 UTC

Description Paul Cuzner 2019-10-14 21:19:16 UTC
Description of problem:
After installing cockpit-ceph-installer, you run the ansible-runner-service script to standup the ansible api service. this script creates the directories used by the container, but is missing an ISO directory required for the ceph-ansible ISO installation method.

Version-Release number of selected component (if applicable):
cockpit-ceph-installer-0.9-1

How reproducible:
100%

Steps to Reproduce:
1. install cockpit-ceph-installer
2. run ansible-runner-service.sh
3. look at the directory under /usr/share/ansible-runner-service - iso is missing

Actual results:
missing iso directory

Expected results:
iso should be there by default

Additional info:

Comment 1 RHEL Program Management 2019-10-14 21:19:24 UTC
Please specify the severity of this bug. Severity is defined here:
https://bugzilla.redhat.com/page.cgi?id=fields.html#bug_severity.

Comment 2 Paul Cuzner 2019-10-15 22:50:06 UTC
fixed in upstream commit 4b4a52b99bb396e532dc06cf6561128e89925891

Comment 6 errata-xmlrpc 2020-01-31 12:47:36 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0312


Note You need to log in before you can comment on or make changes to this bug.