Bug 1761682 - [Feature:OAuthServer] [Token Expiration] Using a OAuth client with a non-default token max age to generate tokens that expire shortly works as expected when using a token authorization flow
Summary: [Feature:OAuthServer] [Token Expiration] Using a OAuth client with a non-defa...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: apiserver-auth
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.3.0
Assignee: Stefan Schimanski
QA Contact: scheng
URL:
Whiteboard:
: 1761687 1762181 1762225 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-10-15 05:28 UTC by xiyuan
Modified: 2020-01-23 11:08 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-23 11:07:31 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift origin pull 23964 None closed Bug 1761682: test oauth server: increase timeout, wait for pod ready first 2020-03-10 18:02:02 UTC
Red Hat Product Errata RHBA-2020:0062 None None None 2020-01-23 11:08:05 UTC

Description xiyuan 2019-10-15 05:28:59 UTC
Description problem:
https://prow.svc.ci.openshift.org/view/gcs/origin-ci-test/logs/release-openshift-ocp-installer-e2e-aws-rhel7-workers-4.2/3 of 

fail [github.com/openshift/origin/test/extended/oauth/expiration.go:30]: Unexpected error:
    <*errors.errorString | 0xc000273410>: {
        s: "timed out waiting for the condition",
    }
    timed out waiting for the condition
occurred

Additional info:

Comment 1 Standa Laznicka 2019-10-15 09:56:36 UTC
*** Bug 1761687 has been marked as a duplicate of this bug. ***

Comment 2 Standa Laznicka 2019-10-16 07:59:37 UTC
*** Bug 1762181 has been marked as a duplicate of this bug. ***

Comment 3 zhou ying 2019-10-16 09:32:23 UTC
*** Bug 1762225 has been marked as a duplicate of this bug. ***

Comment 7 errata-xmlrpc 2020-01-23 11:07:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0062


Note You need to log in before you can comment on or make changes to this bug.