Bug 1761740 - [libdnf] PackageKit segfault with the urlvars commit
Summary: [libdnf] PackageKit segfault with the urlvars commit
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libdnf
Version: 32
Hardware: Unspecified
OS: Unspecified
high
unspecified
Target Milestone: ---
Assignee: Jaroslav Rohel
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1761948 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-10-15 08:31 UTC by Michal Domonkos
Modified: 2020-05-05 07:18 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-05 07:18:39 UTC
Type: Bug


Attachments (Terms of Use)

Description Michal Domonkos 2019-10-15 08:31:43 UTC
Description of problem:

PackageKit segfaults with the following libdnf upstream commit:
https://github.com/rpm-software-management/libdnf/commit/7f1134f97277f1887d3b4b1e31cb13ee7dcbd2e4

Note that the root cause probably lies in the preceding commit:
https://github.com/rpm-software-management/libdnf/commit/b74c32ce949f55314566b1e8230be968838811ff

How reproducible:
always

Steps to Reproduce:
1. # /usr/libexec/packagekitd

Comment 1 Michal Domonkos 2019-10-15 08:35:31 UTC
(In reply to Michal Domonkos from comment #0)
> Description of problem:
> 
> PackageKit segfaults with the following libdnf upstream commit:
> https://github.com/rpm-software-management/libdnf/commit/
> 7f1134f97277f1887d3b4b1e31cb13ee7dcbd2e4

Correction; it's this commit:
https://github.com/rpm-software-management/libdnf/commit/cd12c3fe45d2a316437e95d6c48f2c9fad5e86ce

Comment 2 Michal Domonkos 2019-10-15 08:37:05 UTC
(In reply to Michal Domonkos from comment #0)
> Note that the root cause probably lies in the preceding commit:
> https://github.com/rpm-software-management/libdnf/commit/
> b74c32ce949f55314566b1e8230be968838811ff

This one was also the wrong commit; what I meant was (sorry):

https://github.com/rpm-software-management/libdnf/commit/
7f1134f97277f1887d3b4b1e31cb13ee7dcbd2e4

Comment 3 Michal Domonkos 2019-10-15 09:04:09 UTC
Root cause:

When running with PackageKit, the "environ" external variable is NULL for some reason, and we crash here as a result:

void ConfigMain::addVarsFromEnv()

To fix the crash, we could just add a NULL test, however that wouldn't resolve the problem itself.  Jarek is looking into this.

Comment 4 Jaroslav Rohel 2019-10-15 13:40:35 UTC
I made fix PR: https://github.com/rpm-software-management/libdnf/pull/815

Comment 5 Jaroslav Rohel 2019-10-16 06:26:07 UTC
*** Bug 1761948 has been marked as a duplicate of this bug. ***

Comment 6 Fedora Update System 2019-11-11 09:43:02 UTC
FEDORA-2019-7cafbe66ba has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-7cafbe66ba

Comment 7 Fedora Update System 2019-11-11 09:43:36 UTC
FEDORA-2019-94393775ec has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2019-94393775ec

Comment 8 Fedora Update System 2019-11-12 03:07:33 UTC
dnf-4.2.15-1.fc30, dnf-plugins-core-4.0.11-1.fc30, dnf-plugins-extras-4.0.8-1.fc30, libdnf-0.37.2-2.fc30, librepo-1.11.0-1.fc30, microdnf-3.0.2-1.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-7cafbe66ba

Comment 9 Fedora Update System 2019-11-13 04:56:02 UTC
dnf-4.2.15-1.fc31, dnf-plugins-core-4.0.11-1.fc31, dnf-plugins-extras-4.0.8-1.fc31, libdnf-0.37.2-2.fc31, librepo-1.11.0-1.fc31, microdnf-3.0.2-1.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-94393775ec

Comment 10 Fedora Update System 2019-11-14 06:46:46 UTC
FEDORA-2019-7cafbe66ba has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-7cafbe66ba

Comment 11 Fedora Update System 2019-11-14 06:50:32 UTC
FEDORA-2019-94393775ec has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2019-94393775ec

Comment 12 Fedora Update System 2019-11-15 03:44:58 UTC
dnf-4.2.15-3.fc30, dnf-plugins-core-4.0.11-1.fc30, dnf-plugins-extras-4.0.8-1.fc30, libdnf-0.37.2-2.fc30, librepo-1.11.0-1.fc30, microdnf-3.0.2-1.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-7cafbe66ba

Comment 13 Fedora Update System 2019-11-15 04:38:31 UTC
dnf-4.2.15-2.fc31, dnf-plugins-core-4.0.11-1.fc31, dnf-plugins-extras-4.0.8-1.fc31, libdnf-0.37.2-2.fc31, librepo-1.11.0-1.fc31, microdnf-3.0.2-1.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-94393775ec

Comment 14 Fedora Update System 2019-11-19 01:35:02 UTC
dnf-4.2.15-2.fc31, dnf-plugins-core-4.0.11-1.fc31, dnf-plugins-extras-4.0.8-1.fc31, libdnf-0.37.2-2.fc31, librepo-1.11.0-1.fc31, microdnf-3.0.2-1.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.

Comment 15 Fedora Update System 2019-12-02 19:10:22 UTC
dnf-4.2.15-3.fc30, dnf-plugins-core-4.0.11-1.fc30, dnf-plugins-extras-4.0.8-1.fc30, libdnf-0.37.2-2.fc30, librepo-1.11.0-1.fc30, microdnf-3.0.2-1.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 16 Ben Cotton 2020-02-11 17:42:44 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 32 development cycle.
Changing version to 32.


Note You need to log in before you can comment on or make changes to this bug.