Bug 1761787 - python2-requests fails to install in Fedora rawhide due to retired python2-ipaddress
Summary: python2-requests fails to install in Fedora rawhide due to retired python2-ip...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: python-requests
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Fedora Infrastructure SIG
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1761789 1770743
Blocks: F32FailsToInstall PY2FTBI 1739019
TreeView+ depends on / blocked
 
Reported: 2019-10-15 11:24 UTC by Miro Hrončok
Modified: 2019-11-11 09:29 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-23 05:59:22 UTC
Type: Bug


Attachments (Terms of Use)

Description Miro Hrončok 2019-10-15 11:24:37 UTC
python2-requests-2.22.0-6.fc32.noarch fails to install in Fedora rawhide:

  package python2-requests-2.22.0-6.fc32.noarch requires (python2.7dist(urllib3) < 1.25 or python2.7dist(urllib3) >= 1.25.0), but none of the providers can be installed
  package python2-requests-2.22.0-6.fc32.noarch requires (python2.7dist(urllib3) < 1.25.1 or python2.7dist(urllib3) >= 1.25.1.0), but none of the providers can be installed
  package python2-requests-2.22.0-6.fc32.noarch requires python2-urllib3 >= 1.21.1, but none of the providers can be installed
  package python2-requests-2.22.0-6.fc32.noarch requires python2.7dist(urllib3) >= 1.21.1, but none of the providers can be installed
  package python2-requests-2.22.0-6.fc32.noarch requires python2.7dist(urllib3) < 1.26, but none of the providers can be installed
  nothing provides python2-ipaddress needed by python2-urllib3-1.25.3-6.fc32.noarch

This is most caused by python-ipaddress being retired after being orphaned for 6+ weeks.
Please drop the dependency, or remove the package.

When dropping python2-requests, please coordinate with dependent packages, if any.
Thanks

Comment 1 Jeremy Cline 2019-10-16 14:11:16 UTC
I don't think I can drop the dependency (and I don't have enough time to jump through hoops to make it work without it anyway), but when I drop python2-requests a large portion of whatever remains of the Python 2 stack will collapse. Well, I suppose since it's not installable it's already collapsed.

Since the dependent packages are "pretty much everything" I don't really know how to co-ordinate beyond announcing on devel-list that everything going to break.

Comment 2 Petr Viktorin 2019-10-16 14:20:06 UTC
It's not "pretty much everyhing". The remaining packages are:


- euca2ools (orphaned), which has 3 other packages dependent on it:
  - cloud-utils
  - copr-backend
  - imagefactory-plugins 
- python-requestbuilder (orphaned)
- uhd, gnuradio, gr-* (GNU Radio stack; upstream is python3-ready and work to get the new version in Fedora is going on)
- whipper (to be removed: https://bugzilla.redhat.com/show_bug.cgi?id=1739019 )
- python-jenkinsapi (orphaned)

Comment 3 Jeremy Cline 2019-10-16 14:29:50 UTC
Okay, to put it a different way, installing this package is already broken so those packages are already broken. I'm not going to fix it, so what exactly should I coordinate?

Comment 4 Petr Viktorin 2019-10-16 14:36:30 UTC
Nothing. The bug is automated; the text is generic.

Comment 5 Miro Hrončok 2019-10-16 14:42:59 UTC
I mean just dropping an email to the dependent package owners (if there are some) about this.

The proper thing to do here is to drop python2-requests. There is no other easy way out of here. Sorry for the confusion.


Note You need to log in before you can comment on or make changes to this bug.