Bug 176197 - up2date-nox --configure does not save some attribute changes correctly
Summary: up2date-nox --configure does not save some attribute changes correctly
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: up2date (Show other bugs)
(Show other bugs)
Version: 3.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Bret McMillan
QA Contact: Brandon Perkins
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 179652
TreeView+ depends on / blocked
 
Reported: 2005-12-19 23:34 UTC by Beth Nackashi
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 18:49:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Beth Nackashi 2005-12-19 23:34:55 UTC
Description of problem:
isatty and networkSetup and possibly other attributes are not saved correctly
when exiting up2date-nox --configure.

Version-Release number of selected component (if applicable):
up2date-4.4.56-3

How reproducible:
always

Steps to Reproduce:
1.  Run u2pdate-nox --configure
2.  Change networkSetup or isatty.
3.  <enter> to save
4.  Re-run up2date-nox --configure
  
Actual results:
the new setting was not saved

Expected results:
the new setting was saved

Additional info:
I did not test this for all attributes; there may be others affected.

Comment 1 Adrian Likins 2006-01-16 16:34:59 UTC
isatty will get reset everytime the app ones, it's not really a user
configurable option.

networkSetup doesn't get saved intentionally, see bz # 169881

It just shows up in the nox configure stuff because nox configure is lame. I
say, not a blocker, this isn't new behaviour.

Comment 2 Adrian Likins 2006-01-18 17:57:52 UTC
I'm taking this one off the blocker list, it's lame but it doesn't really break
anything and is old behaviour

Comment 3 Red Hat Bugzilla 2007-04-12 00:23:10 UTC
User bnackash@redhat.com's account has been closed

Comment 4 RHEL Product and Program Management 2007-10-19 18:49:35 UTC
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.


Note You need to log in before you can comment on or make changes to this bug.