Bug 176212 - parttype drop down selection clears previously set review and modify checkbox
parttype drop down selection clears previously set review and modify checkbox
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
5
i386 Linux
medium Severity low
: ---
: ---
Assigned To: David Cantrell
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-20 04:53 EST by David Timms
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-04 11:59:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Timms 2005-12-20 04:53:39 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050923 Fedora/1.7.12-1.5.1

Description of problem:
During graphical installer, the partition choice screen has a checkbox:
Review and modify partitioning layout.

If the remove partitions etc drop down is modified, this check box is cleared.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. At the parttype screen, check the "review and modify item" at the bottom of the screen
2. Choose another partitioning layout.



Actual Results:  The Review and modify checkbox gets disabled.

Expected Results:  The Review and modify checkbox should not change.

Additional info:

Workaround is to click the checkbox again.
Comment 1 David Cantrell 2006-01-04 14:01:02 EST
Bug is resolved, but I modified my fix a bit.  When you select the custom layout
option, the checkbox is forced to true and is greyed out so the user cannot
modify it.  If you then choose another partitioning method, the box is ungreyed
but still left as true.

Instead of that, I have the previous state of the checkbox restored after you
leave the custom layout selection.
Comment 2 David Timms 2006-01-22 07:35:57 EST
David, I tested with FC5T2. The storage of the box state, before checking and
disabling, and restore work as you indicated, and is just that bit nicer than I
was suggesting.
I also notice that the checkboxes throughout anaconda are fading in/out: sort of
cool if you like that sort of thing. Confirmed resolved.
Comment 3 David Cantrell 2006-01-23 11:17:20 EST
Thanks for the followup.  The fading checkboxes are not something I particularly
like because it's difficult to see on older monitors.  It's a GTK+ (or PyGTK, or
Python, or X, or any of a group of things) thing, not something in anaconda.

Thanks again.

Note You need to log in before you can comment on or make changes to this bug.