Bug 1762125 - [RFE] Automate collectd-connectivity plugin via director (TripleO) for integration with SAF
Summary: [RFE] Automate collectd-connectivity plugin via director (TripleO) for integr...
Keywords:
Status: CLOSED DUPLICATE of bug 1761699
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: puppet-collectd
Version: 13.0 (Queens)
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
: ---
Assignee: Martin Magr
QA Contact: Leonid Natapov
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-10-16 01:45 UTC by August Simonelli
Modified: 2019-10-16 21:14 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-16 15:31:10 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description August Simonelli 2019-10-16 01:45:32 UTC
Description of problem:

The preferred method for SAF to monitor node connectivity is with the collectd-connectivity (collectd::plugin::connectivity::interfaces) plugin. See: https://redhat-service-assurance.github.io/saf-documentation/#appe-saf-collectd-plugins

However this plugin is not supported for deployment with OSP 13 director/tripleo.

As per https://bugzilla.redhat.com/show_bug.cgi?id=1754769#c7 this plugin will need code added to work in OSP 13 ("connectivity plugin in osp13 will probably require a rebase of puppet-collectd in osp13"). 

If we are to require/recommend this plugin for SAF then we need to support it for easy deployment on OSP with director.

Version-Release number of selected component (if applicable):
OSP 13+

How reproducible:
No method to deploy 

Steps to Reproduce:
1. No way to deploy 
2.
3.

Actual results:
collectd-connectivity is not able to be deployed.

Expected results:
A way to deploy and configure collectd-connectivity with tripleo.

Additional info:

Please note we also need to ensure we don't only fix the puppet but we include all the deployment logic into the triple templates. I am not sure if that requires another RFE. 

Please advise and I can raise it.

Comment 1 Matthias Runge 2019-10-16 10:53:05 UTC
Is this a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1761699 ? 

If this here is not asking for more than providing the necessary puppet capabilities to generate a configuration for collectd-connectivity (and the other NFVPE related plugins), then it is a duplicate. To me, this is a duplicate.

If you need more to be implemented here, please be more specific.

Comment 2 Martin Magr 2019-10-16 15:31:10 UTC
It is, puppet-collectd upstream definitely have connectivity plugin implemented.

*** This bug has been marked as a duplicate of bug 1761699 ***


Note You need to log in before you can comment on or make changes to this bug.