Bug 1762216 - [build-cop] terraform packet_device provisioning time limit exceeded
Summary: [build-cop] terraform packet_device provisioning time limit exceeded
Keywords:
Status: CLOSED DUPLICATE of bug 1776011
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.3.0
Assignee: Scott Dodson
QA Contact: David Sanz
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-10-16 08:44 UTC by Lukasz Szaszkiewicz
Modified: 2019-12-11 14:29 UTC (History)
0 users

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-12-11 14:29:33 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift release pull 5498 0 'None' 'closed' 'Bug 1762216: metal-e2e unified boot image when available' 2019-12-02 13:32:26 UTC

Description Lukasz Szaszkiewicz 2019-10-16 08:44:52 UTC
Description of problem: The following jobs https://prow.svc.ci.openshift.org/job-history/origin-ci-test/logs/release-openshift-ocp-installer-e2e-metal-4.3 and https://prow.svc.ci.openshift.org/job-history/origin-ci-test/logs/release-openshift-ocp-installer-e2e-metal-serial-4.3 fail constantly. 

The issue seems to be the inability to provision "packet device". The following error appears in the log frequently (https://ci-search-ci-search-next.svc.ci.openshift.org/?search=provisioning+time+limit+exceeded&maxAge=336h&context=2&type=all)

* packet_device.masters[0]: 1 error(s) occurred:
* packet_device.masters.0: provisioning time limit exceeded; the Packet team will investigate
* module.bootstrap.packet_device.bootstrap: 1 error(s) occurred:
* packet_device.bootstrap: provisioning time limit exceeded; the Packet team will investigate
Terraform does not automatically rollback in the face of errors.

Comment 1 Scott Dodson 2019-10-21 12:41:23 UTC
CI broke because the images for 4.3 bare metal have changed from 'metal-bios' and 'metal-efi' to 'metal' in data/data/rhcos.json. The PR now looks for 'metal-bios' and if that's not found it looks for 'metal'. This is specific to our CI jobs so I'm not sure how QE would test this other than to look at the job history where it failed continuously early in the installation process, now it fails less frequently and usually because certain e2e tests return negative results.

https://prow.svc.ci.openshift.org/job-history/origin-ci-test/logs/release-openshift-ocp-installer-e2e-metal-4.3

Comment 3 Scott Dodson 2019-12-11 14:29:33 UTC

*** This bug has been marked as a duplicate of bug 1776011 ***


Note You need to log in before you can comment on or make changes to this bug.