Bug 1762314 - Not enabling module deps when installing a pkg
Summary: Not enabling module deps when installing a pkg
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: dnf
Version: 8.1
Hardware: Unspecified
OS: Unspecified
high
unspecified
Target Milestone: rc
: 8.0
Assignee: Jaroslav Mracek
QA Contact: Luca Berton
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-10-16 13:52 UTC by Michal Bocek
Modified: 2020-04-28 16:48 UTC (History)
5 users (show)

Fixed In Version: libdnf-0.38.1-1.el8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-04-28 16:48:23 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:1823 None None None 2020-04-28 16:48:54 UTC

Internal Links: 1783413

Description Michal Bocek 2019-10-16 13:52:32 UTC
Description of problem:
dnf does not enable all module stream dependencies during a pkg installation.

Version-Release number of selected component (if applicable):
dnf-0:4.2.7-6.el8.noarch

Steps to Reproduce:
1. Make sure perl and perl-YAML modules are not enabled
2. # dnf install perl-YAML
Installing:
 perl-YAML                 noarch               1.24-3.module+el8.1.0+2934+4e5567df   rhel-8-for-x86_64-appstream-rpms    93 k
Enabling module streams:
 perl-YAML                                      1.24
3. # dnf check
Modular dependency problem: Problem: conflicting requests
  - nothing provides module(perl:5.26) needed by module perl-YAML:1.24:8010020190322131811:a5949e2e-0.x86_64

Actual results:
During the perl-YAML installation dnf enabled only perl-YAML module causing a dependency problem described above in step 3.

Expected results:
dnf should have enabled also perl module which seems to be required by the perl-YAML module:
# dnf module enable perl-YAML
Enabling module streams:
 perl                        5.26                                                                                                          
 perl-YAML                   1.24

Comment 1 Jaroslav Mracek 2019-10-21 15:52:53 UTC
I create PR that resolves the issue: https://github.com/rpm-software-management/libdnf/pull/821
CI/gating tests: https://github.com/rpm-software-management/ci-dnf-stack/pull/658

Comment 3 Michal Bocek 2019-10-30 14:08:32 UTC
Are you planning to release the fix also in 8.1.z?

Comment 9 errata-xmlrpc 2020-04-28 16:48:23 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:1823


Note You need to log in before you can comment on or make changes to this bug.