Bug 176247 - Message says to report to bugzilla, but all such bugzilla reports are closed without action
Message says to report to bugzilla, but all such bugzilla reports are closed ...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: system-config-printer (Show other bugs)
4
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
https://bugzilla.redhat.com/bugzilla/...
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-20 11:27 EST by Jeff Epler
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-20 11:38:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Epler 2005-12-20 11:27:12 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

Description of problem:
On the terminal, system-config-printer reports messages similar to this one:
system-config-printer prints the following message:
  No match for USB device:
    mfr "Samsung"
    model "ML-2010"
    desc ""
    cmdset "GDI"
  Please report this message in Bugzilla:
    https://bugzilla.redhat.com/bugzilla
  Choose 'foomatic' as the component.
but when the report is filed, it is quickly closed as UPSTREAM.

Version-Release number of selected component (if applicable):
system-config-printer-0.6.131.3-1

How reproducible:
Always

Steps to Reproduce:
1. Attach an unrecognized printer
2. Run system-config-printer
3. Look at message in terminal window
  

Actual Results:  The message "Please report this message in bugzilla" as shown above

Expected Results:  A message that directs the user to report this data http://www.linuxprinting.org/contribute.html#data


Additional info:
Comment 1 Tim Waugh 2005-12-20 11:37:41 EST
No, the bug reports are acted upon:

1. if there is an existing entry for that printer, the autodetection string is
added (or in some cases, corrected).  Examples: bug #176224, bug #174957 (just
from today)

2. if there is no entry for that printer, the owner of the printer needs to
contact the linuxprinting project in order to give them enough details to add an
entry.  If I did that myself, I'd just be the middle-man and chinese whispers
might cause incorrect details to be added.  In the case of the ML-2010, I can
see from CVS that no entry exists upstream yet, so it is appropriate to put
owners in contact with the linuxprinting project.

Another reason for directing reports here instead of linuxprinting is that there
may be several thousand people with a particular printer model, but the
autodetection string only needs to be corrected once -- and it is likely that
reports of problems already corrected upstream would lead to all reports being
ignored eventually.

So, I am acting here as a filter to

a) correct foomatic XML when necessary
b) point people with printer models not covered by foomatic to linuxprinting
c) prevent the linuxprinting project folks from getting bombarded with email
because of a warning message added by the Fedora project

Note You need to log in before you can comment on or make changes to this bug.