Bug 1762485 - Firewall-applet not working in F31
Summary: Firewall-applet not working in F31
Keywords:
Status: NEW
Alias: None
Product: Fedora
Classification: Fedora
Component: firewalld
Version: 31
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Eric Garver
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-10-16 20:24 UTC by pmkellly
Modified: 2019-10-16 20:24 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed:


Attachments (Terms of Use)

Description pmkellly 2019-10-16 20:24:53 UTC
Description of problem: The firewall-applet done not function


Version-Release number of selected component (if applicable): 0.7.1-1fc31


How reproducible:100%


Steps to Reproduce:Install fire-wall-applet (sudo dnf install -y firewall-applet
1. restart the system
2.
3.

Actual results: The firewall applet icon is not show in the top bar. There is no notification of successful connection the the network


Expected results: The firewall-applet icon is displayed in the top bar on the right side and to the left of the panel. The icon has right and left mouse click modes that provide quick access to many firewalld functions. Also there is a notification under the clock the shows status of the network connection. The notification happens with each power on start or restart of the system.


Additional info:
The System Monitor application shows firewall applet loaded with a PID, normal priority with 25.9MB memory. I looked at firewall configuration to see if there is now a setting to activate the applet, but there doesn't seem to be anything like that.

the firewall applet has worked fine under gnome for many Fedora releases. The top bar icon function was unusable with F30, but the connection notifications continued to work. With F30 on Intel systems the Icon was a faint dark grey patch and if you pick just the right spot the right and left click functions still worked. On AMD systems the icon was not present. With F31 the firewall-applet does not work at all.

I installed F31 Xfce beta on my test machine. Then I installed the firewall-applet. The applet worked great! I got the connection notification on restart or power up start. I also got the icon in the top bar that provides the left and right click actions someone might want to do quickly in regard to the firewall. So it would seem that the firewall-applet works fine in a friendly environment.


Note You need to log in before you can comment on or make changes to this bug.