Bug 176256 - Console cleared randomly
Console cleared randomly
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Andrew Overholt
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-20 11:53 EST by Thomas Fitzsimmons
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-03 11:09:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Eclipse Project 121592 None None None Never

  None (edit)
Description Thomas Fitzsimmons 2005-12-20 11:53:58 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
When building classpath, which uses custom builders, the console seems to be cleared randomly.  This makes it difficult to debug builds.  Ideally a new console would be created for each *set* of custom builders run and each new console would never be cleared.  When building autotooled projects, it is important to have context for the entire build.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
How it should work:

1. Check out Classpath
2. Project -> Build Project
3. (eclipse creates Console2 tab)
4. Console2 logs "ClasspathAutogen", "ClasspathBuildNative", "ClasspathCreateLocaleData" builders output, and never clears itself


Additional info:
Comment 1 Andrew Overholt 2005-12-20 11:55:04 EST
This should be filed upstream.
Comment 2 Thomas Fitzsimmons 2005-12-20 12:25:48 EST
Mirrored upstream.
Comment 3 Andrew Overholt 2006-02-03 11:09:01 EST
From the upstream bug:

"By default consoles associated with terminated processes are removed when
another process is launched. This can be controlled by a preference. See
Preferences-Run/Debug/Remove terminated launches when a new launch is created."

Note You need to log in before you can comment on or make changes to this bug.