Bug 1762565 - 4.1 to 4.2 upgrade fails, second master is caught in a drain loop wedge and upgrade never completes
Summary: 4.1 to 4.2 upgrade fails, second master is caught in a drain loop wedge and u...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Etcd
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
: 4.2.z
Assignee: Sam Batschelet
QA Contact: ge liu
URL:
Whiteboard:
: 1762005 (view as bug list)
Depends On: 1761557
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-10-16 23:19 UTC by Kirsten Garrison
Modified: 2019-10-30 04:45 UTC (History)
18 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1761557
Environment:
Last Closed: 2019-10-30 04:44:56 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:3151 0 None None None 2019-10-30 04:45:11 UTC

Comment 4 Michael Gugino 2019-10-18 00:43:55 UTC
*** Bug 1762005 has been marked as a duplicate of this bug. ***

Comment 5 ge liu 2019-10-18 10:22:55 UTC
Tried 4.1.20 to 4.2.0 for more than 10 times covered different hypervisor platform, have not trigger this problem, and run some upgrade from 4.1.20 to 4.2 latest version, it passed, we will continue to watch this issue.

Comment 7 errata-xmlrpc 2019-10-30 04:44:56 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:3151


Note You need to log in before you can comment on or make changes to this bug.