Bug 176265 - /etc/profile needs "$EUID" rather than $EUID
/etc/profile needs "$EUID" rather than $EUID
Status: CLOSED DUPLICATE of bug 160731
Product: Fedora
Classification: Fedora
Component: setup (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2005-12-20 13:18 EST by Steve Falco
Modified: 2014-03-16 22:57 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-12-20 13:50:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Steve Falco 2005-12-20 13:18:34 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
If a user logs in with ksh selected as their shell, then the $EUID variable (around line 17 in /etc/profile) will not be set, and the user will get a syntax error.

Simply adding double-quotes around the variable fixes this.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.set shell to ksh in /etc/passwd
2.log in

Actual Results:  Get a syntax error at line 17 in /etc/profile, caused by $EUID being undefined.

Expected Results:  No syntax error.

Additional info:
Comment 1 Bill Nottingham 2005-12-20 13:50:08 EST

*** This bug has been marked as a duplicate of 163637 ***
Comment 2 Bill Nottingham 2005-12-20 13:51:06 EST

*** This bug has been marked as a duplicate of 160731 ***

Note You need to log in before you can comment on or make changes to this bug.