Bug 1762692 - Remove "Namespace" when `oc describe csinode`
Summary: Remove "Namespace" when `oc describe csinode`
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Storage
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: 4.4.0
Assignee: Christian Huffman
QA Contact: Chao Yang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-10-17 09:14 UTC by Chao Yang
Modified: 2020-05-04 11:15 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-04 11:14:34 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift oc pull 292 None closed Bug 1762692: Bump kubectl 1.17 2020-02-18 21:15:57 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-04 11:15:17 UTC

Description Chao Yang 2019-10-17 09:14:58 UTC
Description of problem:
CSINode does not belong to any namespace, no need to add this parameter when `oc describe csinode`

Version-Release number of selected component (if applicable):
4.3.0-0.nightly-2019-10-16-222152

How reproducible:
Always

Steps to Reproduce:
1.oc describe csinode ip-10-0-159-141.us-east-2.compute.internal
Name:         ip-10-0-159-141.us-east-2.compute.internal
Namespace:    
Labels:       <none>
Annotations:  <none>
API Version:  storage.k8s.io/v1beta1
Kind:         CSINode

Actual results:
"Namespace" is displayed when using `oc describe csinode`

Expected results:
Remove "Namespace" when `oc describe csinode`

Master Log:

Node Log (of failed PODs):

PV Dump:

PVC Dump:

StorageClass Dump (if StorageClass used by PV/PVC):

Additional info:

Comment 1 Christian Huffman 2019-11-14 13:49:23 UTC
Submitted a PR upstream [1] to address this issue. This PR introduces a CSINode Describer, so that it will no longer use the generic Describer and display the namespace.

[1] https://github.com/kubernetes/kubernetes/pull/85283

Comment 2 Christian Huffman 2020-02-04 19:15:45 UTC
The upstream PR has been merged. Submitting a cherrypick [1] to the openshift repo for inclusion in our oc binaries.

[1] https://github.com/openshift/kubernetes-kubectl/pull/15

Comment 6 Chao Yang 2020-02-14 07:59:46 UTC
Passed with
Client Version: v4.4.0
Server Version: 4.4.0-0.nightly-2020-02-13-212616
Kubernetes Version: v1.17.1


oc describe csinode
Name:               ip-10-0-140-210.us-east-2.compute.internal
Labels:             <none>
Annotations:        <none>
CreationTimestamp:  Fri, 14 Feb 2020 12:23:10 +0800
Spec:
Events:  <none>

Comment 8 errata-xmlrpc 2020-05-04 11:14:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.