Bug 1762701 - [ceph-dashboard]Filesystems - No details are disaplayed for Ranks, Pools,MDS Performance upon selecting the filesystem.
Summary: [ceph-dashboard]Filesystems - No details are disaplayed for Ranks, Pools,MDS ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Ceph-Dashboard
Version: 4.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: 4.0
Assignee: Ernesto Puerta
QA Contact: Madhavi Kasturi
Anjana Suparna Sriram
URL:
Whiteboard:
: 1772788 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-10-17 09:40 UTC by Madhavi Kasturi
Modified: 2020-02-08 12:35 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-31 12:47:36 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Ceph Project Bug Tracker 41372 0 None None None 2019-11-14 19:34:15 UTC
Ceph Project Bug Tracker 43052 0 None None None 2019-11-28 10:27:12 UTC
Github ceph ceph pull 29800 0 'None' closed mgr/dashboard: CephFS tab component 2020-03-25 09:21:39 UTC
Github rhcs-dashboard ceph pull 83/commits/10ae9cafb7280ed7ebadb81a06c76dff00dbf1fa 0 None None None 2020-03-25 09:21:39 UTC
Red Hat Product Errata RHBA-2020:0312 0 None None None 2020-01-31 12:47:46 UTC

Comment 1 Ernesto Puerta 2019-11-14 19:34:16 UTC
This couldn't be reproduced in upstream Nautilus (v14) with vstart Cephfs (2xMDS), so perhaps this could be a downstream-only issue.

Traceback found in ceph-mgr log:

"Traceback (most recent call last):
  File "/lib/python3.6/site-packages/cherrypy/_cprequest.py", line 670, in respond
    response.body = self.handler()
  File "/lib/python3.6/site-packages/cherrypy/lib/encoding.py", line 220, in __call__
    self.body = self.oldhandler(*args, **kwargs)
  File "/lib/python3.6/site-packages/cherrypy/_cptools.py", line 237, in wrap
    return self.newhandler(innerfunc, *args, **kwargs)
  File "/usr/share/ceph/mgr/dashboard/services/exception.py", line 88, in dashboard_exception_handler
    return handler(*args, **kwargs)
  File "/lib/python3.6/site-packages/cherrypy/_cpdispatch.py", line 60, in __call__
    return self.callable(*self.args, **self.kwargs)
  File "/usr/share/ceph/mgr/dashboard/controllers/__init__.py", line 649, in inner
    ret = func(*args, **kwargs)
  File "/usr/share/ceph/mgr/dashboard/controllers/__init__.py", line 842, in wrapper
    return func(*vpath, **params)
  File "/usr/share/ceph/mgr/dashboard/controllers/cephfs.py", line 32, in get
    return self.fs_status(fs_id)
  File "/usr/share/ceph/mgr/dashboard/controllers/cephfs.py", line 159, in fs_status
    mds_versions[metadata.get('ceph_version', 'unknown')].append(
AttributeError: 'NoneType' object has no attribute 'get'

Additionally, downstream Mgr API mgr.list_servers() shows 'mds.0' detached from any host (while upstream one properly displays 'mds.a' attached to its host).

Comment 3 Ernesto Puerta 2019-11-15 12:07:54 UTC
*** Bug 1772788 has been marked as a duplicate of this bug. ***

Comment 20 errata-xmlrpc 2020-01-31 12:47:36 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0312


Note You need to log in before you can comment on or make changes to this bug.