Bug 176281 - Logging in via X session not possible: login screen blank
Logging in via X session not possible: login screen blank
Status: CLOSED NOTABUG
Product: 389
Classification: Community
Component: Directory Console (Show other bugs)
7.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Rich Megginson
Chandrasekar Kannan
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-20 15:07 EST by Graham Leggett
Modified: 2015-01-04 18:19 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-22 12:54:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of the problem (60.34 KB, image/tiff)
2005-12-20 15:07 EST, Graham Leggett
no flags Details

  None (edit)
Description Graham Leggett 2005-12-20 15:07:55 EST
When attempting to run the startconsole application remotely via
X over ssh (client: Fedora Directory console on RHEL4, server: X11 for MacosX
v10.4.3), the login screen flashes briefly with the login parameters, then goes
blank as per the attached screengrab.

In addition, as the background splash screen is bigger than the login screen
window, clicking on the splash screen hides the login screen making it
impossible to either log in or shut down without killing startconsole.
Comment 1 Graham Leggett 2005-12-20 15:07:55 EST
Created attachment 122466 [details]
Screenshot of the problem
Comment 2 Rich Megginson 2005-12-20 15:32:13 EST
Looks like the splash screen is causing more problems.  Try
startconsole -x nologo .....

Nathan, I think we are going to need to put some sort of timer on the splash
screen to make it disappear after a few seconds, or something like that.
Comment 3 Graham Leggett 2005-12-20 17:02:24 EST
Just tried the -x nologo, and the logo dutifully disappears, but the login
window still stays blank. :(
Comment 4 Rich Megginson 2005-12-20 17:45:53 EST
What version of java are you using?  This is usually some problem with the
interaction between java and X and/or the window manager.
Comment 5 Graham Leggett 2005-12-20 17:55:50 EST
The Java version is 
[root@gatekeeper fedora-ds]# java -version
java version "1.5.0_05"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_05-b05)
Java HotSpot(TM) Client VM (build 1.5.0_05-b05, mixed mode, sharing)

The same version works fine from X locally on the machine, as soon as it's over
X over ssh it doesn't want to work. :(
Comment 6 Rich Megginson 2005-12-20 17:58:09 EST
Yes.  We always have weird problems with using java and a remote display.  I've
seen similar problems over the years with PCAnywhere, VNC, remote X display
(especially if the host system X version is not exactly the same as the client
system X version).
Comment 7 Graham Leggett 2005-12-21 04:15:59 EST
Is this a Java problem or a Fedora console problem? Not being able to use the
console via X is a serious limitation on the usefulness of the console.
Comment 8 Rich Megginson 2005-12-21 09:03:24 EST
It's a java problem.
One way to work around the console remote display problem is to install the
console locally, and have it connect to the remote ldap and admin server via
ldap and http.
Comment 9 Rich Megginson 2008-12-22 12:54:05 EST
I'm going to close this bug as notabug, and just hope that some later version of java will not have this problem.

Note You need to log in before you can comment on or make changes to this bug.