Bug 176283 - Postfix binary does not support pam-mysql.
Postfix binary does not support pam-mysql.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: postfix (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Woerner
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-20 15:35 EST by Nad
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-21 07:16:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nad 2005-12-20 15:35:49 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

Description of problem:
I have been using Fedora Core 4 to host a few virtual domains with great
success. I prefer to use all the base packages that comes with the fedora
distribution and this makes it easy to update the system for any security
issues.

Initially when I was trying to setup Postfix for virtual domains, I was
trying to use MySQL through Pam and it was much of a dissapointment to find
out that Postfix package provided with the fedora core 4 distribution is not
compiled using the pam-mysql option. Since I prefered using the binaries
provided by the distribution rather than recompiling the source rpms each
time there is an update available, I decided to setup Postfix with OpenLDAP
authentication. However, my preference would be to use MySQL. This is a
trivial change to Postfix package included in the distribution to also
support pam-mysql rather than users would have to recompile and lose the
ability to conveniently update. Reading some of the forums, I found many
other users unhappy with this.

You can ask to include this change for FC5 and it would be very much liked
by the user community who are using fedora to host virtual domains. This
option should also be available for vsftpd to be able to use pam-mysql
authentication.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. setup postfix as default mta
2. configure postfix to use virtual user/domains map from pam-mysql
3. error message shows that postfix binary is not compiled with mysql option
  

Additional info:
Comment 1 Christian Iseli 2007-01-22 05:56:13 EST
This report targets the FC3 or FC4 products, which have now been EOL'd.

Could you please check that it still applies to a current Fedora release, and
either update the target product or close it ?

Thanks.
Comment 2 Nad 2007-01-22 08:25:53 EST
This issue still applies to FC6 as well as the current dev of FC7 release.
Comment 3 Martin Jürgens 2007-06-21 07:30:51 EDT
Maybe related to bug 185515.
Comment 4 Thomas Woerner 2007-11-07 07:21:59 EST
Please have a look at the postfix-2.4.5-3 package in devel. MySQL support is now
enabled.
Comment 5 Thomas Woerner 2007-11-21 07:16:14 EST
Fixed in rawhide.

Note You need to log in before you can comment on or make changes to this bug.