Bug 1763 - slocate unusable until /etc/cron.daily/slocate.cron first run
Summary: slocate unusable until /etc/cron.daily/slocate.cron first run
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: slocate
Version: 1.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Thomas Woerner
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-03-24 22:20 UTC by Jason Cooper
Modified: 2014-07-25 03:45 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-10-15 18:40:22 UTC


Attachments (Terms of Use)

Description Jason Cooper 1999-03-24 22:20:37 UTC
slocate will not function until this is run, which may
create initial confusion for users immediately after
installation.

Comment 1 Preston Brown 1999-03-25 00:21:59 UTC
Matt, maybe we should run it as part of the post installation
procedure?

Comment 2 Michael K. Johnson 1999-03-26 19:07:59 UTC
Install time would be bad (it would get some files and not others
if it was started in the middle of the install, and it could mess
up disk space calculations); even spawning it at boot could be
bad because it could conflict with the cron version starting,
which means it needs to use a lock file if we choose to do this.
I'd rather see a more general approach to the problem.  locate
complained as well.

Comment 3 Cristian Gafton 1999-04-12 17:08:59 UTC
This should be done as part of a larger schdeule of tasks that would
be run at the first boot into the new installed system.

This would require some re-engineering work for now, so I guess people
will have to live with locate not working on the first day.

Comment 4 Aleksey Nogin 2002-10-25 22:18:56 UTC
Is this problem still around? If so, I would guess that slocate.cron could be
added to firstboot now.

Comment 5 Barry K. Nathan 2004-07-14 16:24:02 UTC
Yes, this problem is still around, but (aside from RHEL 3) it's
ameliorated by anacron; the delay is now a little over an hour, not up
to a whole day as before. (Perhaps anacron was also around when this
bug was first filed, but I really don't know one way or the other.)

Especially with the existence of anacron, trying to fix this may not
be worth the bother. As it is, users already need to be aware that
locate is using a snapshot that could be up to a day old; in
comparison, not having locate work for the first hour (or so) after
installation is a very minor issue IMO.

Comment 6 Thomas Woerner 2004-10-15 18:40:22 UTC
This is already fixed, so closing as "NOT A BUG" anymore.


Note You need to log in before you can comment on or make changes to this bug.