Bug 176303 - exportfs -u does not remove individual entries from /var/lib/nfs/xtab or /proc/fs/nfs/exports, and umount fails
exportfs -u does not remove individual entries from /var/lib/nfs/xtab or /pro...
Status: CLOSED DUPLICATE of bug 172100
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: nfs-utils (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Steve Dickson
Ben Levenson
Depends On:
  Show dependency treegraph
Reported: 2005-12-20 20:55 EST by Mitchell Brandsma
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-01-09 11:12:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Mitchell Brandsma 2005-12-20 20:55:49 EST
Description of problem:
We have an nfs server exporting 2 filesystems, which should not be interrupted 
(hence we cannot simply restart the nfs service).

I have configured further ext3 filesystems to export, for the moment read only, 
and exportfs presents these to clients as expected.  However, after mounting an 
exported filesystem from a client, then unmounting it, exportfs -u does not 
completely remove export entries.  References are removed from:-

but do not go from:-

Because the kernel entry is still there (is that because of the xtab entries 
still there, or causing the xtab entries to still be there?), we are unable to 
umount it.  Restarting nfs does fix the problem, but doing so interferes with 
an important application.

Version-Release number of selected component (if applicable):
nfs-utils-1.0.6-42EL with kernel-smp-2.4.21-37.EL

How reproducible:
Every time.

Steps to Reproduce:
1. (server): exportfs -o mp,ro,no_root_squash \*:/stage/test
2. (client): mount server:/stage/test /mnt/test ; umount /mnt/test
3. (server): exportfs -u \*:/stage/test
4. umount /stage/test
Actual results:
# fuser -v /stage/test
                     USER        PID ACCESS COMMAND
                     root     kernel mount  /stage/test

# umount /stage/test
umount: /stage/test: device is busy

This remains the case until nfs is restarted on the server.

Expected results:
Filesystem should have umounted properly.  I would also expect xtab references 
for the unexported share to disappear.

Additional info:
If the filesystem is simply exported and then unexported, without being mounted 
at all then there is no problem.  But once the entries appear 
in /var/lib/nfs/xtab and /proc/fs/nfs/exports then those entries will not go 
until nfs is restarted on the server.
Comment 3 Lon Hohberger 2006-01-05 11:10:52 EST
Hi, if you downgrade to 1.0.6-38 or older, does the problem go away?  I.e., can
you unmount the file system?
Comment 4 Lon Hohberger 2006-01-05 11:19:33 EST
Sorry - clarification - if you downgrade nfs-utils to version 1.0.6-38 or older
(for example, 1.0.6-33 is known to make this problem go away), can you unmount
the file system?
Comment 5 Steve Dickson 2006-01-09 11:12:44 EST
The patch for this problem is in Bug# 172100

*** This bug has been marked as a duplicate of 172100 ***
Comment 6 Mitchell Brandsma 2006-11-14 08:51:49 EST
The answer to this is I don't know, I don't have the older package, and this 
is a production system I can't play with anyway.  However, I suspect that is 
the case.  The problem was resolved in bug 172100 with the nfs-utils-1.0.6-
43EL package.

Go the 1 line patch!

Note You need to log in before you can comment on or make changes to this bug.