Bug 176306 - unable to start miniChinput due to font setting
unable to start miniChinput due to font setting
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: miniChinput (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Qingyu Wang
Bill Huang
: i18n
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-20 23:26 EST by Lawrence Lim
Modified: 2014-03-25 20:52 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-21 23:58:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lawrence Lim 2005-12-20 23:26:29 EST
Description of problem:
chinput is not able to start because it tires to load a font which does not exist.

Version-Release number of selected component (if applicable):
miniChinput-0.0.3-56.0.i386

How reproducible:
Always

Steps to Reproduce:
1.open terminal and run the command 'chinput'
2.
3.
  
Actual results:
Chinput Version 3.0.2 -- XIM Server
Distributed under the terms of the GNU General Public License (GPL)
Basic: Cannot open font -misc-zysong18030-medium-r-normal--0-0-0-0-c-0-iso10646-1


Expected results:
starts chinput properly

Additional info:
Checked with maintainer and confirmed the changes made to the file
/usr/lib/Chinput/Chinput.ad, will allow the chinput to start properly.

--- /usr/lib/Chinput/Chinput.ad 2005-12-20 23:23:09.000000000 -0500
+++ /usr/lib/Chinput/Chinput.ad.new     2005-12-20 23:25:41.000000000 -0500
@@ -66,9 +66,9 @@
 ! 16 point font set
 !
 chinput.font                   =       8x16
-chinput.gbfont                  =      
-misc-zysong18030-medium-r-normal--0-0-0-0-c-0-gb2312.1980-0
-chinput.gbkfont                  =     
-misc-zysong18030-medium-r-normal--0-0-0-0-c-0-gbk-0
-chinput.gb18030font             =      
-misc-zysong18030-medium-r-normal--0-0-0-0-c-0-iso10646-1
+chinput.gbfont      = -misc-ZYSong18030-medium-r-normal--0-0-0-0-c-0-gb2312.1980-0
+chinput.gbkfont     =  -*-*-*-*-*--0-0-0-0-*-0-gbk-0
+chinput.gb18030font =  -*-*-*-*-*--0-0-0-0-*-0-iso10646-1
 chinput.big5font               =      
-taipei-ming-medium-r-normal--16-160-75-75-c-160-big5-0
 !
 !
Comment 1 Qingyu Wang 2005-12-21 05:13:39 EST
After I research it in more detail I found that this is not the bug of
miniChinput. The occurrence of this problem because the system didn't config
fonts correctly. If you execute command "xlsfonts" you will find there is no
font name about zysong18030 in the list. To config fonts correctly just need to
execute the following commands: 
$ xset +fp /usr/share/fonts/zh_CN/TrueType
$ xset fp rehash 
And then without changing Chinput.ad, miniChinput will also start OK.
Comment 2 Lawrence Lim 2005-12-21 10:21:44 EST
That's great but that would that involved having end users to entering the
command everytime the system restarts? If so, perhaps modifying Chinput.ad and
rebuild the package will be more beneficial to end users. What do you think?
Comment 3 Leon Ho 2005-12-21 20:18:27 EST
Can someone look into the problem when X does not include fontpath of
/usr/share/fonts/zh_CN/TrueType. i.e. Please check /etc/X11/fs/config? 
Comment 4 Qingyu Wang 2005-12-21 23:57:03 EST
This problem occurs because of the use of vnc. After re-setup vncserver the
problem is gone and miniChinput starts OK.
Comment 5 Lawrence Lim 2005-12-22 00:00:52 EST
Thanks for looking into this issue so promptly. Starting vnc with the X font
server using -fp option will allow the fonts to load properly.

vncserver -geometry 800x600  -fp unix/:7100

Note You need to log in before you can comment on or make changes to this bug.