Bug 176308 - segfault compiling C++ code in poppler
segfault compiling C++ code in poppler
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-21 00:08 EST by Dave Malcolm
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-21 16:52:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Preprocessed source that caused the crash (94.93 KB, application/octet-stream)
2005-12-21 00:08 EST, Dave Malcolm
no flags Details

  None (edit)
Description Dave Malcolm 2005-12-21 00:08:08 EST
Description of problem:
doing a jhbuild of poppler on a rawhide box:

make
make  all-recursive
make[1]: Entering directory `/home/david/jhbuild-gnome-2.14/src/poppler'
Making all in goo
make[2]: Entering directory `/home/david/jhbuild-gnome-2.14/src/poppler/goo'
if /bin/sh ../libtool --tag=CXX --mode=compile g++ -DHAVE_CONFIG_H -I. -I. -I..
-I../poppler     -Wall -Wno-unused -g -O2 -MT gfile.lo -MD -MP -MF
".deps/gfile.Tpo" -c -o gfile.lo gfile.cc; \
then mv -f ".deps/gfile.Tpo" ".deps/gfile.Plo"; else rm -f ".deps/gfile.Tpo";
exit 1; fi
mkdir .libs
 g++ -DHAVE_CONFIG_H -I. -I. -I.. -I../poppler -Wall -Wno-unused -g -O2 -MT
gfile.lo -MD -MP -MF .deps/gfile.Tpo -c gfile.cc  -fPIC -DPIC -o .libs/gfile.o
gfile.cc: In member function 'void GDir::rewind()':
gfile.cc:705: internal compiler error: Segmentation fault
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla> for instructions.
Preprocessed source stored into /tmp/ccbijF8W.out file, please attach this to
your bugreport.


Version-Release number of selected component (if applicable):
gcc-4.1.0-0.9

How reproducible:
Seems to be entirely reproducable at this end ATM
Comment 1 Dave Malcolm 2005-12-21 00:08:09 EST
Created attachment 122481 [details]
Preprocessed source that caused the crash
Comment 2 Jakub Jelinek 2005-12-21 10:57:41 EST
I can't reproduce it:

g++ -v; g++ -g -O2 -Wall -Wno-unused -fPIC 176308.ii -c; echo $?
Using built-in specs.
Target: i386-redhat-linux
Configured with: ../configure --prefix=/usr --mandir=/usr/share/man
--infodir=/usr/share/info --enable-shared --enable-threads=posix
--enable-checking=release --with-system-zlib --enable-__cxa_atexit
--disable-libunwind-exceptions --enable-libgcj-multifile
--enable-languages=c,c++,objc,obj-c++,java,fortran,ada --enable-java-awt=gtk
--disable-dssi --with-java-home=/usr/lib/jvm/java-1.4.2-gcj-1.4.2.0/jre
--host=i386-redhat-linux
Thread model: posix
gcc version 4.1.0 20051214 (Red Hat 4.1.0-0.9)
0
Comment 3 Dave Malcolm 2005-12-21 16:52:39 EST
Have subsequently updated that machine and am unable to reproduce

Note You need to log in before you can comment on or make changes to this bug.