Bug 1763167 - Retire python2-matplotlib in Fedora 32+
Summary: Retire python2-matplotlib in Fedora 32+
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: python2-matplotlib
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Mattias Ellert
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1739520 (view as bug list)
Depends On:
Blocks: PY2REMOVAL F31_PY2REMOVAL 1739540 1751491 1763170 1763171 1763172
TreeView+ depends on / blocked
 
Reported: 2019-10-18 11:59 UTC by Miro Hrončok
Modified: 2019-10-21 10:01 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-21 03:39:13 UTC
Type: ---


Attachments (Terms of Use)

Description Miro Hrončok 2019-10-18 11:59:19 UTC
In line with the Mass Python 2 Package Removal [0], all (sub)packages of python2-matplotlib were marked for removal:

 * python2-matplotlib
 * python2-matplotlib-test-data
 * python2-matplotlib-tk
 * python2-matplotlib-wx

According to our query, those (sub)packages only provide a Python 2 importable module. If this is not true, please tell us why, so we can fix our query.

Please retire your package in Rawhide (Fedora 32).

Please don't remove packages from Fedora 31, it is past Beta Freeze.
Please don't do this for Fedora 30/29 either, removing packages from a released Fedora branch is forbidden.

If there is no objection in a week, we will retire the package for you.

We hope this doesn't come to you as a surprise. If you want to know our motivation for this, please read the change document [0].

[0] https://fedoraproject.org/wiki/Changes/F31_Mass_Python_2_Package_Removal

Comment 1 Miro Hrončok 2019-10-18 12:02:18 UTC
*** Bug 1739520 has been marked as a duplicate of this bug. ***

Comment 2 Mattias Ellert 2019-10-21 03:39:13 UTC
Package was retired.

Comment 3 Miro Hrončok 2019-10-21 10:01:18 UTC
Thanks!


Note You need to log in before you can comment on or make changes to this bug.