Bug 176345 - Curly brace repetition broken with multibyte chars?
Curly brace repetition broken with multibyte chars?
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: grep (Show other bugs)
4.0
x86_64 Linux
medium Severity low
: ---
: ---
Assigned To: Tim Waugh
Mike McLean
:
Depends On:
Blocks: 187538
  Show dependency treegraph
 
Reported: 2005-12-21 11:50 EST by Phil Regier
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version: RHBA-2006-0224
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-22 11:36:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Phil Regier 2005-12-21 11:50:35 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Description of problem:
echo "abc123def456ghi"|egrep --color "^[[:alpha:]]{3}([[:digit:]]{3}[[:alpha:]]{3}){2}"

fails to return a result; however,

echo "abc123def456ghi"|LANG=C egrep --color "^[[:alpha:]]{3}([[:digit:]]{3}[[:alpha:]]{3}){2}"

works as intended.  This behavior results from RHEL4 source, but not from the equivalent Fedora 4 package (2.5.1-48), which behaves as expected without being coerced to LANG=C.

Version-Release number of selected component (if applicable):
grep-2.5.1-31

How reproducible:
Always

Steps to Reproduce:
1.  echo "abc123def456ghi"|egrep --color "^[[:alpha:]]{3}([[:digit:]]{3}[[:alpha:]]{3}){2}"
2.  echo "abc123def456ghi"|LANG=C egrep --color "^[[:alpha:]]{3}([[:digit:]]{3}[[:alpha:]]{3}){2}"
3.  Compare the output.  Repeat on Fedora if necessary.
  

Additional info:

A possible relationship with bug  #143079 has been suggested.
Comment 9 Red Hat Bugzilla 2006-03-22 11:36:06 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0224.html

Note You need to log in before you can comment on or make changes to this bug.